LEARNING OUTCOMES
This tutorial will help you understand what a spreadsheet is and where a spreadsheet might come in useful for classroom management. Specifically you will learn about the following topics.

- Helpful hints for understanding the basic concepts of a spreadsheet, including:
  - cells, rows and columns
  - cell coordinates
  - entering data into a spreadsheet cell
- Setting up labels, including:
  - setting column widths
  - aligning data in cells
  - entering column and row labels
- Creating and copying formulas
- Making changes in a spreadsheet
  - inserting rows and columns
  - deleting rows and columns
- Producing a printed copy of the contents of a spreadsheet document
- Saving a backup copy of your work
- Appreciating the power of spreadsheet templates
A caveat before you begin: You'll find it easiest to use the tutorial if you follow the directions carefully. On computers there are always other ways of doing things, but if you wander off on your own be sure you know your way back!

4.1 GETTING STARTED

Showing the Full menus and organizing the Toolbars
Recall from Lessons 1 and 2 that, when using any of the Office programs, it is best to be able to see the full menus at all times. Unless you set the Customize options to show the full menus, you will only see a few of the items in each menu at the top of the Word window. So let's start out by setting the Option in Excel to “Always show full menus.”

Open Microsoft Excel if you have not already done so (on your computer it's probably in the Start menu > All Programs > Spreadsheets)

In the Tools menu, select Customize..., then in the dialog box that pops up, select the Options tab (Fig. 4.1)

![Customize dialog box]

Fig. 4.1 The Customize dialog box

Make sure there is a check mark next to the item to Always show full menus

While you're at it, check the box next to Show Standard and Formatting toolbars on two rows, List font names in their font, and Show ScreenTips on toolbars

Click the Close button when you're done
Lesson 4: Introduction to the Excel Spreadsheet

On with the tutorial...

Some background

Fig. 4.2 illustrates a typical spreadsheet for keeping track of student grades.

| R35 | A          | B | C | D | E | F | G | H | I | J | K | L | N | D | P |
|-----|-------------|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|
|     | Grade Report |   |   |   |   |   |   |   |   |   |   |   |   |   |   |
| 1   |             | A | B | C | D | E | F | G | H | I | J | K | L | N | D | P |
| 2   |             |   |   |   |   |   |   |   |   |   |   |   |   |   | 59%| F |
| 3   | Class; Grade 4 |   |   |   |   |   |   |   |   |   |   |   |   |   | 60%| D |
| 4   | Semester 1   |   |   |   |   |   |   |   |   |   |   |   |   |   | 70%| C |
| 5   | Year; 2002   |   |   |   |   |   |   |   |   |   |   |   |   |   | 80%| B |
| 6   |             |   |   |   |   |   |   |   |   |   |   |   |   |   | 90%| A |
| 7   |             |   |   |   |   |   |   |   |   |   |   |   |   | A1 |   |   |
| 8   |             |   |   |   |   |   |   |   |   |   |   |   |   | A2 |   |   |
| 9   |             |   |   |   |   |   |   |   |   |   |   |   |   | A3 |   |   |
| 10  |             |   |   |   |   |   |   |   |   |   |   |   |   | A4 |   |   |
| 11  |             |   |   |   |   |   |   |   |   |   |   |   |   | A5 |   |   |
| 12  |             |   |   |   |   |   |   |   |   |   |   |   |   | TOTAL|   |   |
| 13  |             |   |   |   |   |   |   |   |   |   |   |   |   | POINT|   |   |
| 14  |             |   |   |   |   |   |   |   |   |   |   |   |   | GRADE|   |   |
| 15  |             |   |   |   |   |   |   |   |   |   |   |   |   | 1% | A  |
| 16  |             |   |   |   |   |   |   |   |   |   |   |   |   | MAX  |   |   |
| 17  |             |   |   |   |   |   |   |   |   |   |   |   |   | 20  |   |   |
| 18  |             |   |   |   |   |   |   |   |   |   |   |   |   | 20  |   |   |
| 19  |             |   |   |   |   |   |   |   |   |   |   |   |   | 30  |   |   |
| 20  |             |   |   |   |   |   |   |   |   |   |   |   |   | 100 |   |   |
| 21  |             |   |   |   |   |   |   |   |   |   |   |   |   | 20  |   |   |
| 22  |             |   |   |   |   |   |   |   |   |   |   |   |   | 190 |   |   |
| 23  |             |   |   |   |   |   |   |   |   |   |   |   |   | 100%|   |   |

Fig. 4.2 Gradebook for a 4th Grade class

As illustrated in Fig. 4.2, the leftmost column of a spreadsheet is often reserved for descriptive labels that identify the value stored in each of the cells in any particular row in the grid. The rightmost column and lower rows of a set of figures are often set aside for row and column totals respectively.

In 1978, Dan Bricklin, a young graduate student at the Harvard School of Business, developed a program for an early PC—the Apple II. He called the program Visicalc. It simulated a traditional accounting worksheet. It was, in fact, the very first electronic spreadsheet, a prototype of the many varieties of spreadsheets available today.

The Excel spreadsheet which you are about to learn to use is considerably more powerful than Visicalc. Excel is able to handle much larger sets of numerical data at much greater speeds. Like Visicalc, however, it goes beyond the hand-written worksheet used in traditional accounting in that it is programmable—you can program it to do the math for you! And this was Dan Bricklin’s genius!

We have a multitude of challenges in our everyday lives, so why do math if we can design a machine to do it for us? This doesn’t mean we shouldn’t teach math in schools, of course. What it means is that we should teach math in schools so that our students can understand what the computers can do for them.
You can build instructions into an electronic spreadsheet to do relatively complex mathematical calculation and analysis. You also can build instructions into the spreadsheet to carry out humdrum, repetitive calculations—the kind of calculations which could take hours, even days, to complete manually but which, when done electronically, take a matter of seconds.

The Excel screen is a window onto a large grid of rows and columns (Fig. 4.2) into each cell of which data are entered, usually from the keyboard. You can build formulas into selected cells which automatically carry out calculations on designated sets of data. You'll learn how in this lesson and the next.

The spreadsheet is most used for business accounting and data analysis. In K-12 schools, however, the spreadsheet comes in handy as a tool for keeping grades. It also is useful for creating charts and graphs of all kinds, as well as for data analysis related to class projects where numbers need to be organized, managed, and analyzed. It also is an excellent tool for helping students learn math concepts and has many other applications with students across the curriculum. The Skills Consolidation section at the end of the chapter will give you the opportunity to brainstorm with your classmates in order to come up with a list of such applications.

But first you need to learn more about spreadsheets and how they work.

Practice makes perfect
As with the word processor, the best way to learn about the spreadsheet is to build a spreadsheet document and work with it. So here goes.

You should see on your screen a new Excel spreadsheet document titled Book1.

Close the Excel Task Pane (on the right side of the Excel window) since you won't need it for this lesson.

The default Office name for documents (such as Book1) is always nondescript. So it always is a good idea to immediately name any new document with a recognizable name of your choice. After all, you want to be able to tell what each document contains when you look at a list of the many documents names on your disk.

Shakespeare asked: “What’s in a name?” Well, when it comes to file names on a computer disk, names matter a great deal! You are about to create a template for a gradebook. 1 So a good name for the document might be something like “Grades Template.”

Put your Work Files for Office 2003 Tutorials disk in the disk drive.

Select Save As from the File menu and switch to the drive that contains your Work Files for Office 2003 Tutorials disk.

In the Save As dialog box, click on the Create New folder icon (Fig. 4.3) and name the new folder Spreadsheets.

Fig. 4.3 The New Folder icon in the Save As dialog box.

1 A template is an outline or form which can be used over and over when carrying out other projects that require the same basic document format. Here you are going to build a spreadsheet template to simulate an empty gradebook. Once you have created the template, you will keep it as a template on your disk for future use. You will be able to use this template from semester to semester to build the electronic gradebooks for all your classes.
Lesson 4: Introduction to the Excel Spreadsheet

Type Grades Template as the document name for the new spreadsheet and click on the Save button.

You should now be looking at a screen with the name of your document (Grades Template) at the top of a blank worksheet ready for you to insert your data.

4.2 HELPFUL HINTS WHILE USING THE SPREADSHEET

A spreadsheet is a grid divided into rows and columns.

The intersection of a column and row is referred to as a cell (Fig. 4.3).

Right now, cell A1 is selected in the top left-hand corner of the spreadsheet.

Type the number 2004 in cell A1 so you have some data in the spreadsheet for what follows.

A cell is where information, in the form of either a label, or a number, or a formula for calculation, will be entered.

• Labels are where you use text to describe the data in the columns and rows.
• Numbers are just that—numbers. Numbers are what spreadsheets are all about.
• Formulas are mathematical expressions built into certain cells that instruct the computer to carry out calculations on specified sets of numbers in the rows and columns.

As you go on with the tutorial, these concepts will become clearer to you.

Moving around in the spreadsheet

There are 65536 rows and 256 columns in the Excel spreadsheet. That means there are over 16 million cells into which you can store data! That should be enough for any purposes you might have in mind!
Usually you will use the mouse to select the cell you want to work in by clicking on the cell to select it. Once in a particular cell, use the commands in Table 4.1 to proceed to other related cells.

<table>
<thead>
<tr>
<th>Key Pressed</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab</td>
<td>Moves selection to the right to next cell in same row</td>
</tr>
<tr>
<td>Shift-Tab</td>
<td>Moves selection to the left to previous cell in same row</td>
</tr>
<tr>
<td>Arrow keys</td>
<td>Move selection one cell in any direction</td>
</tr>
<tr>
<td>Shift-Enter</td>
<td>Moves selection up to previous cell in same column</td>
</tr>
<tr>
<td>Enter</td>
<td>Moves selection down to next cell in same column</td>
</tr>
<tr>
<td>Scroll bars</td>
<td>Scroll vertically and horizontally through the spreadsheet</td>
</tr>
<tr>
<td>Accept button (✓)</td>
<td>Accepts data in cell but does not move to another cell</td>
</tr>
<tr>
<td>Cancel button (X)</td>
<td>Cancels entry in cell</td>
</tr>
</tbody>
</table>

Table 4.1 Cell selection commands

Check each option now—this will help you follow later directions

Practice by moving around the spreadsheet—after you have visited several cells, end up by clicking on cell A1 to make it the current or active cell.

**Identifying the active cell's coordinates**

Look in the top left hand corner of the Excel screen (Fig. 4.4) to see which cell (the active cell) you are in at any point in time.

![Fig. 4.4 Identifying the address of the cell you are working in](image)

Click on any cell now and look at the cell’s coordinates in the top left corner of the screen

Each cell (a location in the spreadsheet) has an address which begins with a letter to indicate the column, followed by a number to indicate the row. For example, as illustrated in Fig. 4.4 above, G6 identifies the cell at the intersection of column G, row 6.
Lesson 4: Introduction to the Excel Spreadsheet

Selecting a range (group) of cells
Table 4.2 lists the methods for selecting a group or range of cells.

<table>
<thead>
<tr>
<th>Task</th>
<th>Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>To select a block of cells</td>
<td>Drag from the first cell to the last cell in the block</td>
</tr>
<tr>
<td>To select an entire row of cells (horizontally from left to right)</td>
<td>Click on the number (the row label) on the left hand side of the spreadsheet</td>
</tr>
<tr>
<td>To select an entire column of cells (vertically, from top to bottom)</td>
<td>Click in the letter(s) of the alphabet (the column label) at the top of the column</td>
</tr>
<tr>
<td>To select several rows or columns</td>
<td>Drag across the row or column headings</td>
</tr>
</tbody>
</table>

Table 4.2 Selecting a range (group) of cells

Once again, take a few minutes now to try each of these methods for selecting groups of cells.

Location of the active (selected) cell after entering data into a cell
When you type the data for a cell, the data first appear in the Entry bar at the top of the screen (Fig. 4.5).

![Fig. 4.5 The spreadsheet Entry bar](image)

See how this works for yourself now.

Click on any cell and type the number 2004 and look at the Entry bar above the spreadsheet cells (Fig. 4.5)

The data are displayed there while you

1. check that they are correct before copying them to the active (selected) cell;
2. make up your mind whether they should be entered into the spreadsheet at all;
3. decide which cell you would like to be the active cell next after the data have been copied to the currently active cell.

You may still decide not to enter the data into the spreadsheet.
In this case you would click on the Cancel box (X) in the Entry bar (Fig. 4.5) and start over. If, on the other hand, the data are correct, you would click the Accept button (✓), which keeps the cell you are working in as the active cell.

Click the Accept button (✓) now

Notice that the data are immediately copied to the selected (active) cell.

Alternatively, you may want to proceed to the cell immediately to the right of the active cell into which the number you just typed will go. Or you may want to proceed to the cell just below the active cell, or the cell just above the active cell, and so on.

A short while back you practiced moving around the spreadsheet using the commands listed in Table 4.1. This table also lists the key(s) to press to tell Excel which cell to go to after you accept the data you have typed into the Entry bar.

Practice now by making the cell in which you just typed 2004 the active cell (by clicking on it)

Then press each of the keys or key combinations in Table 4.1 and verify the result of the action in the spreadsheet each time

Blanking out a cell or cells in the spreadsheet

The quickest way to blank out cells is to use the Clear option from the Edit menu.

Select the cell holding the data 2004 then, from the Edit menu, select Clear > All

Let's do that another, simpler, way. First you need to bring back the data you just deleted.

Hit ctrl-z

Now, with the cell still selected, hit the Del(ete) key on the keyboard

This saves you having to use the mouse and menus. To do the same to a group of cells you would just drag across the cells to select them—they will become highlighted. Then select Clear from the Edit menu or hit the Del(ete) key as before.

Practice now by entering 3 or 4 numbers into adjacent cells in the spreadsheet, then select all (ctrl-a) and use the Clear command or the Del(ete) key to remove them in one go

Remember that you can undo the Clear operation (or any other Edit operation) by immediately selecting Undo Clear from the Edit menu (or press ctrl-z).

Editing the data in the Entry bar

While you are typing in data in the Entry bar you can edit them as if you are using Word. So everything you learned in Lessons 1 and 2 will apply.

Editing data after they have been entered into a cell

If you are past the cell where you have an error and want to make a correction or change, move back to the cell in question by selecting (clicking on) it. The data in that cell will be displayed in the Entry bar at the top of the spreadsheet. Click in the Entry bar (the cursor will show where you clicked on the text) and then just go ahead and make any changes you want. Replace the old entry by clicking the Accept button (✓) or by selecting another cell in the spreadsheet.
4.3 Setting up Labels for Your Gradebook Template

When you have completed this section and the next section (Sections 4.3 and 4.4) your gradebook should look like Fig. 4.6.

![Fig. 4.6 Gradebook template](image)

The steps that follow will help you achieve this goal. Follow them carefully.

**Select cell A2 and type Grade Report**

Check the data in the Entry bar to make sure you typed the label correctly; correct any errors.

Click the Accept button (✓) when you are sure all is well (or press one of the other keys which accept data into the spreadsheet—arrow keys, Enter/Enter key, Tab key).

This is an example of a label—which is any text you use to describe the data that are in a spreadsheet. All the column and row headings are labels also.

You need to widen the A column to allow for longer student last names.

**From the Format menu select Column/Width...**

Type the number 15 in the dialog box, then click on OK.

While you're at it, click anywhere in the B column (first name) and adjust the width to 12.

Later in this section you'll practice adjusting other column widths.

**Select cell A4**

Type the label Class: (note the colon) and press Enter to move the cell pointer to cell A5.

Type the label Semester: and press Enter to move the cell pointer to cell A6.
Finally type the label **Year:** and click on the **Accept** button (✓) in the **Entry bar**

At this point you should be thinking about saving the work you have completed thus far! Since you have already named the document (Grades Template), you can use a quick keyboard shortcut.

**Press ctrl-s** to save your work to this point

**Aligning data in spreadsheet cells**

The gradebook will look best if the three labels you just entered into the spreadsheet were right aligned in their respective cells. Right aligned means that the label is aligned to the right side of the cell. Unless you tell Excel otherwise, the system will left align any data that are regular text (letters of the alphabet, for example). Likewise, the system will right align any data that are made up of numbers. This makes sense if you look at Fig. 4.7.

Text is usually left justified on the page, while numbers are easiest to work with when they are right justified

| Text is usually left justified | 23 |
| on the page, while numbers are easiest to work with | 345 |
| when they are right justified | 2360 |
| ----- | 4 |
| Total | 2732 |

**Fig. 4.7 Text is left aligned; numbers are right aligned**

However, sometimes text looks best when it is right aligned in the cell, as should be the case with the labels you just entered into cells A4, A5, and A6. Here is how you right align the text in these cells.

Position the spreadsheet cursor on cell **A4**

Hold down the mouse button and drag down to cell **A6**, so that all three cells are selected (cell A4 will still be selected even though it is not highlighted—it has the heavier border which also indicates selection in the spreadsheet)

In the **Format** tool bar click on the **Right Alignment** button

This will right align the cells that you have selected (A4 through A6). Check this on the screen before you go on.

**Press ctrl-s** to save your work so far (this is a good habit to get into!)

**Entering the column and row labels**

Now you will enter the labels for each of the columns that eventually will contain the scores for assignments you might give your students during the course of a school session.

Select cell **D8** and enter the grade label **A1** (short for **Assignment 1**)

Check that you have typed the label correctly, then press the **Tab** key to move to the next cell across and enter the assignment label **A2**
Lesson 4: Introduction to the Excel Spreadsheet

Do the same thing three more times, using the labels A3, A4, and A5 (Your last entry should be in cell H8)

Click the Accept button (✓) next to the entry bar at the top of the screen

These labels might represent homeworks or quizzes for a unit or for a whole semester, depending on how many assignments you might assess for grading purposes. When you use this Grades Template document for an actual gradebook, you will edit these column labels so that they contain appropriate titles relating to the actual assignments that will be stored in the respective columns. There is, of course, room in the gradebook for you to include as many assignments as you want.

Once you have entered all five of the assignment labels, press the right arrow key twice; this should bring you to cell J8

Type TOTAL then press the Tab key 2 times to move to cell L8

Type PCNT then press the Tab key 2 times to move to cell N8, then type GRADE and click the Accept button (✓)

Now you will enter the row label for the Maximum Scores.

Select cell C10, type MAX (this row will be used in due course to keep a record of the maximum score for each assignment, test, and so forth), then click the Accept button (✓)

Finally, you need to enter the column labels for the First and Last names.

Select cell A12 and type LAST NAME, then click the Tab key to go to cell B12

Type FIRST NAME, then click the Accept button (✓) and press ctrl-s again to save your work so far

Entering "dummy" scores

For the template you will enter a set of "dummy" maximum scores (zeroes). Later in the tutorial you will edit these Maximum Scores to reflect maximum scores for actual assignments.

Move to cell D10 and enter the number 0 (zero)

Enter a 0 (zero) for the Maximum Score into each of the remaining assignment columns (E10 through H10)

Adjusting the width of columns

You will notice that the numbers are not quite lined up under the labels in the assignment columns. In Excel the labels (text in general) are aligned on the left of the column while numbers are always aligned on the right (check Fig. 4.7 above if you're still confused about this).

To improve the appearance to your gradebook you probably want your column labels to be more in line with your entries. You already practiced one way of doing this: namely, to right align the labels. Another way is to reduce the width of the columns containing scores. They need be no wider than the width of the column labels. By default Excel makes all the columns about an inch wide (8.43 is the Excel default value for the column width). Let's change the width of columns C through N so they are only as wide as necessary.

Use the horizontal scroll bar at the bottom of the spreadsheet window to scroll the gradebook over until Column C is at the left edge of the spreadsheet.
Use the mouse pointer on the column header "C" at the top of the column (Fig. 4.8)

![Column headers](image)

Fig. 4.8 The Column headers (letters of the alphabet) and Row headers (numbers)

Hold down the mouse button, and keep it down, while you drag across the screen to the right as far as Column H

When you have columns C through H selected, let go of the mouse button

All six columns (C through H) should be highlighted.

From the Format menu select Column/Width...

This will bring up the Column Width dialog box.

Type 4, and click on OK, then click anywhere to deselect the columns

Now use the horizontal scroll bar if necessary to scroll the spreadsheet to the right until you can see column A again

Another way to change Column Widths is to drag with the mouse. Let's try this.

Position the mouse pointer in the column headers between column B and column C so the pointer becomes a crosshair (Fig. 4.9)

![Column headers](image)

Fig. 4.9 Adjusting column width using the mouse

Now just drag left or right and notice the small box that tells you the exact column width
You can simultaneously change the widths of several columns, provided you want them all to be the same width, by selecting (highlighting) all of them first and then dragging in this way.

Try this for yourself now by widening or narrowing all 6 of the columns from Column B to Column G, and then hit ctrl-z to restore the columns to their previous width.

Do this a few more times, widening or narrowing the column width of a few adjacent columns (columns next to each other), each time hitting ctrl-z to restore the columns to their previous width.

Changing the alignment of the column labels:
It would also be a good idea to change the alignment of the column labels so that they are all center aligned.

Position the mouse over cell D8, hold down the mouse button, and drag across to cell H8 before letting go of the mouse button.

All the column labels for the 5 assignments should now be highlighted.

In the Format tool bar click on the Center Alignment button.

Other columns in the spreadsheet also are wider than necessary. Here’s what you need to do:

Reduce the width of the columns listed in Table 4.3 to the width indicated:

<table>
<thead>
<tr>
<th>Column</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>I, K, &amp; M</td>
<td>1</td>
</tr>
<tr>
<td>J and N</td>
<td>8</td>
</tr>
<tr>
<td>L</td>
<td>10</td>
</tr>
</tbody>
</table>

Table 4.3

Change the alignment of the labels for columns J, L, and N to Center Aligned.

Press ctrl-s again to save your work when you have completed this exercise.

4.4 Creating and Copying Formulas
Functions and Formulas are powerful tools in spreadsheets which can save you hours of work.

Functions are routines that are built into the Excel spreadsheet—in other words, there’s not much you need to do to set them up and make the work.

Formulas, on the other hand, are defined by the user—in other words, you have to really know what you’re doing and set everything up yourself.

Formulas will often include the built-in functions as part of the formula.

Both functions and formulas accomplish the same task: they tell Excel to do some kind of more or less complex calculation for you.

For example, at the end of a semester you will want to calculate a total point value, and probably a percentage, for each student. To do this, you can program the spreadsheet to carry out a formula on the values in the cells that contain the students’ scores. You can have the spreadsheet add up the numbers in a set of cells. Or you can have the spreadsheet tell you the
average score in a range of cells, and so on. You can also have the system copy a formula into other cells.

Let's try a few things along these lines now.

Creating the formula
Let's enter a formula and see what it does.

Select cell J10, type =SUM(D10:H10), then click the Accept button (√).

The "=" symbol at the beginning is a clue to the system that what follows is a formula. So remember this:

**ALL SPREADSHEET FORMULAS BEGIN WITH THE EQUALS (=) SIGN**

The formula =SUM(D10:H10) tells Excel to sum (add together) the scores entered in cells D10 through H10 and store the result in cell J10, J10 being the selected cell in which you want the formula to do its job. SUM is one of many Excel built-in functions. It automatically carries out the series of additions to produce the required result.

We’ll look at the built-in functions in a moment.

Notice the 0 (zero) that now appears in cell J10. This number is the sum of the zeroes you typed in cells D10 through H10.

In a short while you will have an opportunity to test whether the formula is correct. You will be entering into the spreadsheet a maximum score for real assignments along with a set of scores for a roster of students.

For now, if you typed in the formula correctly and clicked the Accept button (√) you should see that J10 contains the sum of all the maximum scores (which for the time being is 0 (zero), of course).

Press ctrl-s again to save your work.

Copying and pasting formulas
Soon you will be entering a set of data for several students. But first you must complete the Grades Template by creating a formula that will produce a total or sum of the eventual scores for each student.

Before you carry out the exercise, here is a description of what is involved. Fig. 4.10 on the next page illustrates the process.

You are going to copy the formula from cell J10 to the relevant cells in the same TOTAL column. You will start by copying the formula to the clipboard. Then you will paste it into the first of the cells where you want the formula duplicated. Finally you will tell Excel to "fill down" a copy of the formula to the remainder of the relevant cells in the column—one for each student in the roster.

**Copying the formula...**

Select cell J10 if it is not still selected from the previous exercise.

Press ctrl-c to copy the contents of the cell to the clipboard (or, a quicker way to go, right click while pointing on the cell and select copy from the pop up menu; or, a slower way to go, from the Edit menu select Copy).

Cell J10 will now have a blinking border indicating that this is the cell from which the data have been copied.
Lesson 4: Introduction to the Excel Spreadsheet

The formula in cell J10 has been copied to the clipboard. Let’s take a look at the clipboard now. It’s useful to know how to check the clipboard’s contents.

**From the Edit menu, select Office Clipboard...**

Think of the clipboard as a temporary holding area for a single set of data. Once something is on the clipboard it can be pasted anywhere you want—in this spreadsheet, or in another spreadsheet, or into some other document altogether, such as a Word document, PowerPoint document, Paint document, and so on.

**Pasting the formula...**

Row 14 is where you will enter the first student's name and scores when you create an actual gradebook after you have saved this template. So you are going to paste the formula you just copied (you copied it from cell J10) into cell J14.

**Select cell J14**

**Press ctrl-v (this is the short cut command for selecting Paste from the Edit menu)**

Look at cell J14. You should see the value 0 (zero) stored there. Now look at the data in the Entry bar at the top of the spreadsheet. Interesting! The formula is different from the one you copied from cell J10.

**Check this out—click on cell J10 again**

Notice that the range of cells is D10 through H10.

Now click on cell J14 again
The range of cells is D14 through H14. So Excel automatically adjusted the range so that it would make sense in row 14 (where the first student's scores will be). This is called Relative referencing—let’s think about that.

Relative references
You might find this a trifle tricky to follow, so put on your thinking cap! The system is copying the formula in cell J10 to cell J14 in relation to ("relative to") cell J10. In other words, just as the formula in J10 sums the values stored in cells D10 through H10, so the formula copied to cell J14 will sum the values relative to cells D14 through H14.

Does that make sense to you? If so, give yourself a pat on the back! If not, don't despair. Read it over a couple of times. The alternative to a Relative Reference, by the way, is an Absolute Reference. You will need to use an Absolute Reference shortly, at which time you will more easily understand what it means in the context of the exercise. Bet you can't wait to check it out!

Press ctrl-s again to save your work so far (are you getting into the habit of doing this?)

Filling down (copying the formula into the rest of the TOTAL column)
Excel provides a neat tool to duplicate the contents of cells into a set of adjacent cells. For the sake of this exercise we will assume you will have just ten students in your class. You are going to duplicate the formula that is in cell J14 into the other nine cells below it. As before, Excel will automatically adjust the cell addresses so that they are appropriate (relative) to each student's record.

Select cell J14, if it is not already selected
Use the mouse button to drag down to highlight all the cells from cell J14 to cell J23

Notice that the set of cells from J14 through J23 are now selected as a block on the screen.

From the Edit menu select Fill/Down (ctrl-d for short)

This command copies the formula down to the end of the selected set of cells. For now, a zero will appear in each cell of the TOTAL column (Fig. 4.11).
Fig. 4.11 "A zero will appear in each cell of the TOTAL column."

This is because you have not yet entered any scores. Later, when you do enter the scores, the current total for each student will appear in the TOTAL column.

Press ctrl-s again

Setting up the Percentage formula
The next formula you need will go in the PCNT column (column L) and will calculate the percentage for each student. The formula will tell Excel to divide the Total Points earned by a particular student by the Total of all the Maximum Scores for each assignment.

Select cell L14, since this is the cell in the PCNT column for the first student

The formula you want will divide the value in cell J14 (which is the Total points for the first student) by the value in cell J10 (which is the Total maximum score possible).

Type the formula =J14/J10 (don't forget the “=” sign which tells Excel that you are about to type a formula) and press Enter

Error messages are OK as long as they make sense
Hmmm... The entry #DIV/0! is displayed in cell L14. What on earth is that? you’re probably wondering.

Well, this is an error message warning you that the formula in cell L14 is asking Excel to divide by zero (the current value in J10)—which is an illegal operation because it is undefined in math.

In one sense, you don't need to worry about this error message for now. You will eventually have a value other than zero in cell J10 when you put actual Maximum scores into the Gradebook and this will take care of the #DIV/0! message.

But the error message does not actually include the word "error", so that might be confusing to someone who does not understand what is going on—maybe even you! This might be the case if, for example, you shared the Gradebook template with a colleague at your own or another school.

Fortunately, Excel provides a way around such strange messages.

Using Logical functions
Excel has a useful built-in function for dealing with errors such as this. It's called the logical IF function. The whole function looks like this: =IF(Logic expression, Value if True, Value if False).

Actually, for the record, Excel has over 100 functions divided into nine categories.
 Let’s look at the built-in functions now so that you can know how to find them when you need them.

From the Insert menu select Function... or click on the Insert Function ( ) icon in the Excel data entry bar

The Insert Function dialog box appears on the screen (Fig. 4.12 on the next page).

In the Insert Function dialog box > select a category: menu, click on the Logical category (Fig. 4.12 next page)
Look at the set of 6 **Logical** functions which appear in the new dialog box (Fig. 4.13)
Notice the IF logical function—the third one listed in the Select a function: area of the dialog box.

Double click to select the IF function now, and notice that the data entry boxes for the required components of the IF function (called the Function Arguments) are displayed in the Function Arguments dialog box (Fig. 4.14)

Fig. 4.14 The Function Arguments dialog box

- The Logical test data entry box must have a statement which the spreadsheet will evaluate as either true or false. For example 2+2=5 will be evaluated as false; 2+2=4 will be evaluated as true.
- The value_if_true data entry box is what you want the spreadsheet to put in the cell if the Logical expression is true.
- The value_if_false data entry box is what you want the spreadsheet to put in the cell if the Logical expression is false.

Try the following example for practice. It will be easier to begin with if you just type in the formula yourself instead of using the built-in function template provided by Excel. Built-in function templates are really useful when you know what you’re doing. But let’s keep it simple for now.

Close the Function Arguments dialog box by clicking on the Cancel button

Click in cell A30 and type the formula:

=IF(2+2=5,"How can that be True?","Of course it's False!")

Click on the check mark (✓) to accept the formula into cell A30

We know that 2+2=5 is False, so the result that will be displayed in cell A30 will be "Of course it's False!"

Check the contents of cell A30—it should read Of course it's False!

Notice, by the way, that the result of a function can be text; it doesn't have to be a number.

Select Clear from the Edit menu, or hit Del(ete) to remove the formula from cell A30
Now let’s do the same thing, but this time we’ll use the template for the Logical IF function illustrated in Fig. 4.15 on the next page.

![Function Arguments dialog box](image)

Fig. 4.15 The updated Function Arguments box

Make sure you still have cell A30 selected and click on the Insert Function (fx) icon in the Excel data entry bar

In the Insert Function dialog box > select a category: menu, click on the Logical category

Double click to select the IF function to bring up the Function Arguments dialog box

In the Logical_test box type 2+2=5

In the Value_if_true box type “How can that be True?” (notice the very necessary quotes (" ") around the phrase, which are used to tell Excel that the value is just plain old text, not a number as such)

In the Value_if_false box type “Of course it’s False!” (don’t forget those quotes!) and click on OK

There! Same result, different method for getting there.

Back to the Division by zero problem

OK, in cell L14 you want to tell Excel that if the value in cell J10 is zero (0), it should put a phrase such as "Div by 0 error" as an error message in cell L14.

This will make it easier for users to understand what the error is all about (provided they already know that you can’t divide by zero, of course). It will also remind users (who may well be you) that those Maximum Scores, all of which are zero (0) in the Gradebook template, will need to be updated before the spreadsheet will work with an actual class of students.

The formula that you want to enter in cell L14 must also tell Excel what to do if the value in cell J10 is other than zero (0)—which it will be if there are scores other than zero. In this case, you will tell Excel to go ahead and calculate the percentage for the student.

Now, how would you write that as a formula so that you get the correct result in this particular cell (cell L14)? If you think you can figure it out for yourself (and you'll impress your instructor no end if you can!), write down the correct formula in the box below:
The answer is.... (drum roll...)

```
=IF(J10=0, "Div by 0 error", J14/J10)
```

Go ahead and type this formula into cell L14 now

Absolute references

You need to make one small change to the formula in cell L14 before you copy it to each of the cells from L15 through L23. This is because part of the formula needs to be an Absolute Reference.

Look at the formula again:  
```
=IF(J10=0, "Div by 0 error", J14/J10)
```

Cell J10 contains the total of the maximum scores. The percentage for every student is calculated by using the value in this specific location. So the reference to this cell must not change when the formula is copied to the other cells in column J. This is why it is called an Absolute Reference—it must not change; it must always reference cell J10.

The value in J14, on the other hand, is relative to (or related to) the student data in row 14. This reference (to cell J14) will change relative to each student.

Does that make sense? Read the previous paragraph over again if you need to. The fact is that you must tell Excel that you want any references to J10 in the formula specified for cell L14 to be Absolute, otherwise the formula will not copy correctly to the other cells in column J.

Follow these steps to do this.

Select cell L14

In the Entry bar above the spreadsheet you should see the formula:

```
=IF(J10=0, "Div by 0 error", J14/J10)
```

Position the cursor immediately after the first parenthesis and before J10

Type a dollar sign ($) before the letter J, and another dollar sign ($) before the number 10

The formula will now be:

```
=IF($J$10=0, "Div by 0 error", J14/$J$10)
```

The $ signs tell Excel to treat the reference to column J and row 10 as Absolute when copying the formula to other cells. The reference to J14, on the other hand, will be Relative and will therefore change relative to whichever cell it is copied to, so there's no need for dollar signs there. Remember:

A dollar sign ($) before each part of a spreadsheet cell address tells Excel to treat the reference to the cell as an absolute (unchanging) reference.

Look at the formula again, in particular the second reference to cell J10 at the far end of the formula (J14/J10)? You're going to need $ signs there, too.

Go ahead and type the $ signs (J14/$J$10) just as you did at the beginning of the formula

So the final version of the formula is this:  
```
=IF($J$10=0, "Div by 0 error", J14/$J$10)
```

Phew! That's the tough part over with.
Click on Accept (√) to accept the formula, then press ctrl-s to save the change.

Now that you have edited the formula, you want to copy it to the other cells in the PCNT column. There are a couple of ways you can do this. One way is to use the Edit menu:

**Cell L14** should still be selected, so use the mouse to drag down and select all the cells from cell L14 to cell L23 (Fig. 4.16), then from the **Edit** menu select **Fill/Down**

![Fig. 4.16 Dragging to select the cells to copy into](image)

That’s the old-fashioned way, which is fine. Another, quicker, way is to use the handle in the lower right corner of the cell that you want to copy to the other cells above or below or to the right or to the left (Fig. 4.17).

![Fig. 4.17 Using the active cell’s handle to copy the contents of one cell to other cells](image)
Voilà! All the appropriate cells have been set to calculate the percentage for every student once you have entered a set of scores for each student. Right now, remember, you have the "Div by 0 error" message in each cell because you are telling Excel to divide by zero. As you know, this problem will be overcome when you enter an actual set of maximum scores into row 10.

Press ctrl-s again to save your work so far

Notice that you are doing all the hard work up front. Once you have built the template, using it as a gradebook will be easy. You have a few more tasks to complete before the template is ready.

Setting the Cell Attribute for the PCNT column

When you divide one number by another the result is usually a fraction. Thus the eventual percentage for each student won't look like percentages at all. Instead of, say, 85%, the computer will display 0.85. It would be best to display the percentages as whole numbers (no fractions) with a % sign after them. So you need to add this feature to the Gradebook template.

Follow these steps to format (select attributes for) the values in the PCNT column so they will eventually look like recognizable percentages.

If necessary, drag the mouse from cell L14 to cell L23 and, in the Format menu, select Cells...

In the Format cells dialog box, from the Category menu select Percentage

Then click on OK because the number of decimal places after the decimal point (called Precision) is set at the default of two (2)

That's it. When you add students and their scores to your roster you will see all the percentages displayed with the % sign. You are now ready to save your template for the last time (ctrl-S).

Checking out the formulas

It is useful for you to know how to check out the formulas in the spreadsheet. Like everything else, this is easy enough to do when you know how.

From the Tools menu select Options..., then in the Options dialog box (Fig. 4.18) select the View tab
Fig. 4.18 Showing or not showing formulas and other options in the Options dialog box

In the **Window options** section, put a **check mark** in the box next to **Formulas**, and click **OK**

This will display all the formulas in your spreadsheet. *Excel* widens the columns so you can see the whole of each formula.

Scroll over if necessary to check out the formulas displayed in columns J and L

After you have verified that the formulas are stored correctly relative to each of the appropriate cells, you should reset the display so you can see the values in the cells.

From the **Tools** menu select **Options**, make sure you have the **View tab** selected, then click to deselect **Formulas**, and click on **OK**

Notice that the formulas are hidden once again and the columns restored to their original width.

The last summary column in the spreadsheet (column N) is for the final letter grade. For the purposes of this tutorial, you will enter the grade yourself based on the totals, averages, and other factors that you consider significant in assessing the quality of your students' work. Thus, no formula will be supplied for this column at this time. Later, in Lesson 4, you will learn how to create a Lookup table so that *Excel* can calculate each student's grade and automatically enter it into the spreadsheet. This will simplify your work still more.

### 4.5 ENTERING NAMES AND SCORES FOR EACH STUDENT

**Changing the name of the template document**

Now that the template is safely saved on disk, you can start to use it to build specific gradebooks for particular classes.

As you can see, the template is still on the computer screen after you have saved a copy of it on your disk. Now you are going to fill it out with student names and scores. Thus, the template will no longer be a template; it will be an actual grade roster. Therefore, the first thing you must do is change its name, so that when you save the document it will not overwrite the template that you want to keep for future use. It is always a good idea to do this straight away because you might forget to do it later.

Up until now you have been working with the document that you originally called "Grades Template." Let's say you are a 4th Grade teacher, and the year is 2004. A good document name for this gradebook would be Grade4 2004.

You probably remember how to change a document name from the previous two tutorials. But in case you don't...

From the **File** menu select **Save As**... and type the name **Grade4 2004**, then click on **Save** to save the spreadsheet in the **Spreadsheets** folder in the **Data Files** folder on your **Work Files for Office 2003 Tutorials** disk

The new document name will appear at the top of the screen. You should start by filling in the specific class and semester details for the new gradebook.

In cell **B4** type **Grade 4**, hit the **Enter** key, type **1** for the semester, hit **Enter again**, then type **2004** for the year and click on **Accept (✓)**

**Entering the student names**
Now select cell A14 (this is where the first student's last name will go)

Type a student's Last Name and hit the Tab key to move to cell B14

Type the student's First Name

Hit Enter, then the left arrow key, to move to cell A15, and do the same for the next student

Repeat these steps until you have a roster of 10 students. Notice how the names are all lined up on the left of the column (text is normally left aligned). It doesn't matter if your names are not in alphabetical order at this time since Excel lets you sort them any time you like, as you will learn later in Lesson 4.

**Entering the scores for each student**

Your next step will be to enter scores for these students. But before you do this you will need to decide what kind of scores they will be—Homeworks, Tests, Quizzes, and so forth.

Select cell D8, and type a brief label in the Entry bar, such as HW1, or Test1, and press the Tab key

Do the same for each of the four other labels for the scores columns. Next you must decide what maximum scores you want for each assignment.

Select cell D10

Type a maximum score for the assignment or test recorded in this column (column D)—a maximum score is the highest possible score that can be achieved for the assignment or test (such as 20 out of 20, or 100 out of a possible 100, and so on)

Move to each of the four other maximum score cells (E10 through H10) and enter appropriate maximum scores

Now look across to column L

Notice that those warning messages in column L have gone. This is because you are no longer telling Excel to divide by zero (0).

Take a look at cell J10 and notice that it now has a value other than 0 (zero)

Next, select D14

This is the first cell in the first column of scores for your students. Type a score for each student (press Enter after each score because you want to go down to cell D23). Remember that the score should be within the Maximum Score range for that HW, Test, Worksheet, or whatever.

Now enter scores for each student in each of the remaining four Assignment categories. If you move across to columns J and L, you should notice how the Totals and Percentages are all kept up to date as you enter each score and the percentages look like percentages! If the columns are filled with ####### signs, this is because the column is not wide enough to show the data. Go ahead and make the columns wider if you need to.

Remember if you ever see those ####### signs in a cell, they're not a problem. They're just an alert to you that you need to make the column wider to fit the size of the data.

The formulas are the most powerful aspect of spreadsheets. When the spreadsheet does the math for you, you begin to appreciate the power of those formulas that you have built into the
Gradebook template. You don't need a calculator any more. The spreadsheet is your calculator and it will save you a significant amount of time.

Once again, don't forget to save your work (ctrl-s)

Everything will be saved under the new name (Grade 2004) on your Data Disk.

4.6 MAKING CHANGES TO YOUR GRADEBOOK

Now that your gradebook is complete and saved on your disk, this does not mean that you cannot make alterations to it. Perhaps a new student needs to be entered onto your roster, or you have accidentally overlooked an assignment and want to enter it into your gradebook, or you decide to add an extra assignment or test to your normal schedule. This can all be done with little effort on your part.

Adding a student to the roster (Inserting rows)

A new student can be added by inserting a row. To insert a row you would select the location ahead of which you want to place the new row or rows (say before Row 16). Excel inserts a new row immediately ahead of the row you have selected. Follow these steps to try this now.

Select row 16 by clicking in the row label (the number 16 at the left edge of the spreadsheet—Fig. 4.19)

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>8</td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>LAST NAME</td>
<td>FIRST NAME</td>
</tr>
<tr>
<td>13</td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>Urchick</td>
<td>Pamela</td>
</tr>
<tr>
<td>15</td>
<td>Gaudick</td>
<td>Barbara</td>
</tr>
<tr>
<td>16</td>
<td>Giorgio</td>
<td>Marilyn</td>
</tr>
<tr>
<td>17</td>
<td>Mitnick</td>
<td>Teresa</td>
</tr>
<tr>
<td>18</td>
<td>Bond</td>
<td>Patrick</td>
</tr>
<tr>
<td>19</td>
<td>Dane</td>
<td>Stephanie</td>
</tr>
<tr>
<td>20</td>
<td>Bond</td>
<td>Andrew</td>
</tr>
<tr>
<td>21</td>
<td>Fraher</td>
<td>Brigid</td>
</tr>
<tr>
<td>22</td>
<td>Brown</td>
<td>Lyn</td>
</tr>
<tr>
<td>23</td>
<td>Potochar</td>
<td>Charlene</td>
</tr>
</tbody>
</table>

Fig. 4.19 Selecting a row

Row 16 will become highlighted on the screen.

From the Insert menu select Rows

You should now see a new empty row. If you inserted the row in the wrong place, remember that you can undo what you just did by selecting Undo Insert from the Edit menu.

Now you must fill the new row with data as in the rest of the spreadsheet.

Make cell A16 the active cell now and fill out a name and a set of scores
You will also need to copy the math formulas from cells J10 and L14 to the respective cells in the TOTAL and PCNT columns.

Move, first, to cell J10 and press \texttt{ctrl-c} (the shortcut for the \texttt{Copy} command)

Move to cell J16 and press \texttt{ctrl-v} (or select \texttt{Paste} from the \texttt{Edit} menu)

Now follow the same procedure to copy the formula from cell L14 to cell L16. After you have copied the formulas you should check to see that the results in the various cells make sense. Mistakes are always possible.

\begin{quote}
NEVER ASSUME THAT THE COMPUTER IS GIVING YOU THE CORRECT DATA. THE DATA ARE ONLY AS GOOD AS THE PERSON WHO ENTERED THEM—AND THAT PERSON IS HUMAN!
\end{quote}

\noindent \textbf{Inserting columns}

To insert a new column, you will select where you want to insert the column—say between columns F and G. \textit{Excel} will insert the new column(s) to the left of the column you select.

Select column \texttt{G} by clicking in the column label (the letter "\texttt{G}" at the top of column \texttt{G} in the spreadsheet)

Column \texttt{G} will become highlighted.

From the \texttt{Insert} menu select \texttt{Columns}

\textit{Excel} inserts an empty column to allow you to enter a new set of data. The column width is set to be the same as the column next to which it is inserted.

Again you will need to fill in a column label in cell G8, a maximum score for that assignment (in cell G10), and a set of actual scores, one for each student in the class.

Notice that the column label you enter in cell G8 is right aligned since you set this attribute across the cells from D8 to H8.

Notice, also, once more that all your totals and percentages are updated to reflect the new set of scores.

\noindent \textbf{Deleting (cutting) rows and columns}

Here are the steps to delete rows or columns from a spreadsheet.

Select a row or column, or a set of rows or columns, by highlighting them, then, from the \texttt{Edit} menu select \texttt{Delete}

No need to practice this now. Just remember where to find this section if you ever need to delete rows or columns from a spreadsheet.

The beauty of an electronic spreadsheet such as \textit{Excel} is that, even when you add or delete rows or columns, the system automatically updates the formulas where appropriate to match the new state of the data. If you make changes like this that you want to keep, you must save your work once again. Do this now.

\begin{quote}
\textbf{Save} your \textit{Grade 4 2004} gradebook document
\end{quote}

\section*{4.7 PRINTING YOUR GRADEBOOK}
You are now going to print a "hard copy" of the gradebook. Unless you decide otherwise, *Excel* will print the page in the Portrait orientation (see Fig. 4.20 on the next page).

If your gradebook is too wide to fit on the 8.5 inch width of standard paper, you can print the gradebook sideways (Landscape orientation). In fact, this is often the best orientation for a spreadsheet because of the “shape” of the data which is often set up in quite a few columns across the screen.

From the **File** menu, select **Page Setup** to bring up the dialog box (Fig. 4.21), and make sure you have the **Page** tab selected

![Page Setup dialog box](image)

**Fig. 4.21 Page Setup dialog box**

Click on the radio button next to **Landscape**, then click on **OK**
In the Page Setup dialog box you can also tell *Excel* to print or not to print gridlines, row and column headings and so forth. You can thus still make changes to the appearance of your spreadsheet on the printed page. Let’s try this now.

From the **File** menu select **Page Setup** again, and click on the **Sheet** tab (Fig. 4.22), then remove the checkmark in the box next to **Row and Column Headings** (if it’s not already removed) and **Gridlines** (again, if it’s not already removed).

![Page Setup dialog box](image)

**Fig. 4.22 Printing without headers or gridlines**

This is to tell *Excel* you do not want those headings in the first printout.

Now, in the **Page Setup** dialog box, click on the **Print**… button to bring up the **Print** dialog box (Fig. 4.23 next page).
In the print dialog box, you can choose the number of copies you would like. As a rule, it is best to have the computer print only one copy (the default number of copies) unless you have a high speed printer, since it is easier to make multiple copies by using a photocopier.

Also, if you have a dot matrix, daisy wheel, or ink jet printer, select draft quality the first time or two, so you don't waste ink (this is not an option with laser printers since laser printers always print best quality).

Another tip, if you have control over your own printer, is to recycle once used paper (clean on one side) for draft copies. You might even start collecting this, instead of throwing it away. Help save the planet!

For Print Range in the Print dialog box, the radio button for All is selected by default. If you look a little lower in the dialog box (in the Print what section) you’ll see that the radio button for Active sheet(s) is also selected by default (see again Fig. 4.22 on the previous page).

These are the appropriate settings for our Gradebook spreadsheet. We’ll check out other options in Lesson 5.

Click on OK to print your Grade 4 2004 gradebook

The printer will print the gradebook so you can hand it in to your instructor. For further reinforcement of the options for printing a spreadsheet, let’s print the Gradebook again, but this time we’ll include the row and column headers and the gridlines using a slightly different method.

Select File > Print, click on the Preview button (lower left corner of the dialog box), click on the Setup button, make sure you have the Sheet tab selected, put a check mark next to Gridlines and next to Row and column headers, click on OK, click on the Print... button, and wait while the printer does its job

Hand in both copies of the Grade 4 2004 gradebook to your instructor
4.8 SAVING A BACKUP COPY OF YOUR WORK
Your last task before completing this session at the computer is to make a backup of your document on the backup disk. The Grade 4 2004 gradebook is still open in Excel. It is also saved on your Work Files for Office 2003 Tutorials Disk, which is in the disk drive.

Take out your Work Files for Office 2003 Tutorials disk and in its place insert your Backup Work Files for Office 2003 Tutorials disk.

From the File menu select Save As... and in the Save As... dialog box select the disk drive that holds your Backup Work Files for Office 2003 Tutorials disk.

Double click to open the Data Files folder, double click again to open the Spreadsheets folder, and click on the Save button.

Wait while the file is being saved, then close Word.

4.9 A WORD ABOUT TEMPLATES AND STATIONERY DOCUMENTS
In the first two lessons, and in this lesson, you have been introduced to the concept and importance of templates. So much of a professional's work is based on standard forms of one kind or another. There are simply dozens of such forms that you either generate yourself or that are generated for you by administrators. They may be ditto masters, grade sheets, attendance registers, sign-up sheets, course schedules, syllabi, correspondence, you name it.

You should think "Template" whenever you use Microsoft Office. "How can I leverage the effort I'm putting into creating this document? Are there parts of it that are common to other documents I have to produce? Is there a template here that I should be saving as a separate document for future use?"

Office uses the term "Stationery" to describe documents that act as templates for word processing, database, spreadsheet, or Presentation applications. A selection of some two dozen "starter" documents are supplied with the software. Over the course of your career you will undoubtedly develop your own set of stationery documents or templates.

The rationale behind templates is personal productivity, where time and ideas are at a premium. Templates are a powerful way of capturing the free flow of ideas in the form of electronic documents which enhance the quality and efficiency of our work.

LOOKING BACK
As you must be aware, there is still a great deal to learn about the Excel spreadsheet, but you are on your way.

This should be enough to give you ideas about using the Excel spreadsheet to keep records of numerical data. Apart from finding out what a spreadsheet is, you have learned how to build a spreadsheet template, including labels and formulas. This included basic layout operations such as expanding the width of selected columns and aligning cells. You also learned how to copy formulas to other cells in the spreadsheet.

You then learned how to change the name of the spreadsheet so that the template could be kept unaltered for later use.
After you filled out the gradebook and saved the set of data for a class, you practiced making changes such as adding or deleting rows and columns, and changing the value format for certain cells to percentages.

Finally, you learned how to print out the entire spreadsheet. This latter function is not something you would do as a matter of course. You might well, however, print out charts based on a spreadsheet in order to include them in a report that you have developed using the word processor. You’ll learn how to do this in Lesson 6.

**LOOKING FORWARD**
The next spreadsheet tutorial will help you learn other important aspects of working with spreadsheets, such as using the Lookup function and creating charts of various kinds.

You are probably becoming familiar by now with the environment called Microsoft Office. As you have no doubt noticed, skills learned using the word processor carry over into the use of the spreadsheet or the database. This is the most important advantage of an integrated software package such as Office. It means that the learning curve is less steep.

You will find that completing the remainder of these tutorials will not be nearly as tough. If you found the first three lessons easy, so much the better.

**SKILL CONSOLIDATION**
Complete as many of these exercises as you can to reinforce what you have learned in Lesson 4.

1. Update Grade4 2004 by adding an extra column for another assignment, quiz, project, or test score and hand in your printout of the new spreadsheet.
2. Add two students, along with their scores for all assignment categories, to the gradebook that you created using this tutorial. Copy the formulas where necessary.
3. Add an extra column for another assignment (HW, Test, etc.), add a student, and update the summary (totals, percentage) columns where appropriate. Update the calendar data in the top left corner of the spreadsheet for a class taking place in the Fall semester, session 1, 2004.
4. Design and create a spreadsheet to handle an income statement for your personal checking account. The income statement will span one full year, from January to December. The leftmost column will contain a list of items that you typically purchase during the course of a month. Then the column headers across the spreadsheet will refer to months in the year. The numbers in the cells will be the financial amounts that you spent on each item per month. Then you will include totals at the bottom of each column (a tally for the month) and totals for each item at the end of each quarter/year. This could become an ambitious group project if you were to add extra features such as weekly data with break points (sub totals) and so forth—very useful, too.
5. Get together with one other classmate and brainstorm for ideas about using the Excel spreadsheet with students K-12. List at least 10 suggestions and describe briefly (a sentence or two) how you would use each of them in a subject area and age group of your choice. Specify the subject area and age group for each idea.