Solving 2D Diffusion Problems at Disk UME by FEMLAB (Comsol Multiphysics)

1. Model Background
This section is concerned about definition and derivation of the necessary equations.

1.1 Equations and Conditions
Fick’s second law for axisymmetric diffusion
\[
\frac{\partial C}{\partial t} = D \left[ \frac{\partial^2 C}{\partial r^2} + \frac{1}{r} \frac{\partial C}{\partial r} + \frac{\partial^2 C}{\partial z^2} \right]
\]  
(1)

Initial condition
\[ C(r, z, 0) = C^* \]

Boundary conditions
\[ C(r, 0, t) = 0 \quad (0 < r \leq 1) \]
\[ C(\infty, z, t) = C^*, \quad C(r, \infty, t) = C^* \]
\[ \frac{\partial C(0, z, t)}{\partial r} = 0, \quad \frac{\partial C(r, 0, t)}{\partial r} = 0 \quad (1 < r) \]

1.2. Dimensionless Parameters
Fick’s second law in a dimensionless form in a cylindrical coordinate (see Appendix 5.1)
\[
\frac{\partial f}{\partial \tau} = 0.25 \left[ \frac{\partial^2 f}{\partial R^2} + \frac{1}{R} \frac{\partial f}{\partial R} + \frac{\partial^2 f}{\partial Z^2} \right]
\]  
(2)

and a dimensionless current (see Appendix 5.2)
\[
Z(\tau) = \frac{i(\tau)}{i_{SS}} = \int_{0}^{1} 2\pi RD \left[ \frac{\partial f(R, 0, \tau)}{\partial Z} \right]_{Z=0} dR
\]  
(3)

where
\[
\tau = \frac{4Dt}{r_0^2}
\]  
(4)
\[
R = \frac{r}{r_0}
\]  
(5)
\[
Z = \frac{z}{r_0}
\]  
(6)
\[ f(R,Z,\tau) = \frac{C(r,z,t)}{C_*} \]  

Note that \( r_0 \) is the electrode radius and \( D_i = 0.25 \).

The symbols used in FEMLAB simulation are \( t, r, \) and \( z \) for \( \tau, R, \) and \( Z \).

2. Setting up and Solving the Problem in FEMLAB 3.0

This section is concerned about use of FEMLAB 3.0.

2.1 Beginning Modeling Process

- Execute FEMLAB. FEMLAB’s Model Navigator window will show up.
- Choose “Axial symmetry (2D)” in Space dimension.

2.2 Draw Mode

2.2.1 Geometry (Define Electrode Geometry)

- Choose “Draw” → “Draw Objects” → “Line”.
- Click the left mouse button at \((0, 0)\) and then at \((0.6, 0)\). Release the button. This line will represent electrode surface. Repeat the same procedure at \((1, 0), (1, 0.8), (0, 0.8)\) and then \((0,0)\).
- Click the right mouse button (this is the only case when you use the right button). You will find a box with 5 boundaries with the subdomain name CO1.
- Double-click the CO1 subdomain. The Object Properties window will show up.
- Choose “1” in the curve selection field and change the \( z \) coordinate value from “0.8” to “50” in the second line of Curve properties. Also, change the coordinate values in the other curve sections as follows.

<table>
<thead>
<tr>
<th>Curve selection</th>
<th>Curve properties</th>
<th>( r )</th>
<th>( z )</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>0</td>
<td>50</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>0</td>
<td>50</td>
</tr>
</tbody>
</table>
Then, press OK. A larger domain is redefined. Use the “Zoom Extents” tool to see the whole domain. The tool is found at the top middle of the window. You can zoom in or out using the “Zoom In” and “Zoom Out” tools. You can also use the “Zoom Window” button to magnify specific area.

2.3 Boundary Mode (Define Boundary Conditions)

- Choose “Physics” → “Boundary Settings”.
- Use the following table to set up boundary conditions.

<table>
<thead>
<tr>
<th>Domain selection</th>
<th>Boundary conditions</th>
<th>Quantity</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Insulation/Symmetry</td>
<td>—</td>
<td>symmetry axis</td>
</tr>
<tr>
<td>2</td>
<td>Concentration</td>
<td>$c_0 = 0$</td>
<td>electrode surface</td>
</tr>
<tr>
<td>3</td>
<td>Concentration</td>
<td>$c_0 = 1$</td>
<td>simulation space limit</td>
</tr>
<tr>
<td>4</td>
<td>Insulation/Symmetry</td>
<td>—</td>
<td>insulator</td>
</tr>
<tr>
<td>5</td>
<td>Concentration</td>
<td>$c_0 = 1$</td>
<td>simulation space limit</td>
</tr>
</tbody>
</table>

- Press OK.

2.4 Subdomain Mode (Define Initial Conditions and Others)

- Choose “Physics” → “Subdomain Settings”.
- Choose “1” in the Subdomain selection. Type “0.25” in the “D isotropic” field. Confirm that the values of “$\delta_b$” and “$R_i$” are “1” and “0”, respectively. Then, the equation at the top of the window is equivalent to eq 2.

\[
\delta_b \frac{\partial c_i}{\partial t} + \nabla (-D_i \nabla c_i) = R \quad \text{(the first term is equal to zero under steady states so that it does not appear.)}
\]

With $D_i = 0.25$, $R_i = 0$, and $\delta_b = 1$, the equation is equivalent to \[\frac{\partial c_i}{\partial t} = 0.25 \nabla^2 c_i\]

The concentration $c_i$ is a fractional concentration so that this equation is equivalent to eq 2.

- Click the “Init” tab to switch to the Init page.
- Type “1” in the Value field of “$c(t_0)$”. This is the initial condition.
Press OK.

2.5 Mesh Mode

- Choose “Mesh” → “Mesh Parameters”.
- Click the “Point” tab.
- Choose “3” in the Point section and type “0.001” in the Maximum element size.
- Press “Remesh” and find in the FEMLAB window that a fine mesh has been created at the electrode edge.
- Click the “Boundary” tab.
- Choose “2” in the Boundary section and type “0.001” in the Maximum element size.
- Press “Remesh” and find in the FEMLAB window that a fine mesh has been created at the surface of the electrode.
- Press OK.

3. Solving and Post-processing Model at Steady State

3.1 Solve Mode

- Choose “Solve” → “Solver Parameters”.
- Choose “Stationary linear” in the Solver section. Then, press “OK”.
- Choose “Solve” → “Solve Problem”. The steady-state concentration profile will appear.
- Press “Zoom Window” button and magnify the area near the electrode surface.

3.2 Post Mode

3.2.1 Flux at Electrode Surface

- Choose “Postprocessing” → “Cross-Section Plot Parameters”.
- Click the “Line Extrusion” tab.
- Select “Line plot” in the Plot type section.
- Select “Diffusive flux, c” as the Predefined quantities in y-axis data.
- Press OK. The graph shows the flux distribution at the electrode surface. Confirm the “edge effect”.

3.2.2 Calculation of Dimensionless Current

- Choose “Postprocessing” → “Boundary Integration”.
- Choose “2” in the Boundary selection and “Normal diffusive flux, c” in the Predefined quantities field.
- Check the box for “Compute surface integral”. Press OK. Find at the bottom of the FEMLAB window,
“Value of surface integral: 0.99???”

The number is the steady-state dimensionless current, \( Z(\tau \to \infty) \).

At the steady state, \( Z(\tau) = \frac{i(t)}{i_{ss}} \to 1 \) so that the value of 0.99?? is sufficiently accurate (less than 1 % error).

### 3.2.3 Concentration Plot (Surface and Contour Plots)

- Choose “Postprocessing” → “Plot Parameters”.
- Click the Surface tab to switch to the Surface page.
- Check that the box of the Surface plot is selected and that “Concentration, c” is selected in the Predefined quantities field.
- Click the Contour tab to switch to the Contour page.
- Select the box of the Contour plot and check that “Concentration, c” is selected in the Predefined quantities field.
- Press OK. The graph shows the concentration profile at the steady state as Surface and Contour Plots.

### 3.2.4 Flux Plot (Arrow Plot)

- Choose “Postprocessing” → “Plot Parameters”.
- Click the Arrow tab to switch to the Arrow page.
- Select the box of the Arrow plot and check that “Diffusive flux, c” is selected in the Predefined quantities section. Change “Number of points” for r and z points in the Arrow positioning field to “200”.
- Press OK. The graph shows the concentration profile at the steady state as Surface, Contour, and Arrow Plots. Look at the arrows at the electrode edge. Use the “Zoom Window” tool to look at the arrows near the electrode surface.
4. Solving and Post-Processing Time Dependent Problem

4.1 Defining Current Values as “I”

- Choose “Options” → “Integration Coupling Variables” → “Boundary Variables”.
- Choose “2” in the Boundary selection.
- Type “I” in the Name field and “2*pi*r*ndflux_c_di”. Integration order is automatically chosen as “4”. Press OK.

4.2 Solve Mode

- Choose “Solve” → “Solve Parameters”.
- Choose “Time dependent” in the Solver field.
- Type “0:0.02:1” in the Times field of the Time stepping section. The values mean that the simulation begins at t = 0, and ends at t = 1 and that calculation is carried out with the interval of \( \Delta t = 0.02 \). Finally, the number of iterations is \( 1/\Delta t = 50 \), resulting in 51 outputs. **Note that you need to change the time parameter to obtain data in different time regime.** So, the parameter “0:0.02:1” is just an example. Press OK.
- Choose “Solve” → “Solve Problem”. It will take a few minutes to finish the simulation.

4.3 Post Mode

4.3.1 Displaying and Exporting Current Values

- Choose “Postprocessing” → “Domain Plot Parameters”.
- Click the “General” tab. Choose “Point plot” in the Plot type section. Also, make sure that all values of the time parameter (0–1) is chosen in the “Solution to use” section.
- Click the “Point” tab. Type “I” in the Expression field of the y-axis data section.
- Press “OK” to find a plot of the current versus time. The current drops rapidly then becomes almost constant as shown in Figure 1a. The apparently constant current, however, is decaying (Figure 1b). Use the “Zoom Window” tool to confirm the decay.

![Figure 1a and b.](image-url)
5. Appendix

5.1 Fick’s Second Law in Dimensionless Form

Eq 1 can be converted into eq 2 by introducing dimensionless parameters defined by eqs 4–7. First, \( C(r, z, t) \) in eq 1 can be replace with \( f(R, Z, \tau) \) by using eq 7

\[
\frac{\partial \xi^* f(R, Z, \tau)}{\partial t} = D \left[ \frac{\partial^2 C^* f(R, Z, \tau)}{\partial r^2} + \frac{1}{r} \frac{\partial C^* f(R, Z, \tau)}{\partial r} + \frac{\partial^2 C^* f(R, Z, \tau)}{\partial \tau^2} \right]
\]

(9)

which can be simplified to

\[
\frac{\partial f(R, Z, \tau)}{\partial t} = D \left[ \frac{\partial^2 f(R, Z, \tau)}{\partial r^2} + \frac{1}{r} \frac{\partial f(R, Z, \tau)}{\partial r} + \frac{\partial^2 f(R, Z, \tau)}{\partial \tau^2} \right]
\]

(10)

Now, eq 10 should be expressed by \( R, Z, \) and \( \tau \) as valuables. First, \( t \) is replaced with \( \tau \). Eq 10 is equivalent to

\[
\frac{\partial \tau}{\partial t} \frac{\partial f(R, Z, \tau)}{\partial \tau} = D \left[ \frac{\partial^2 f(R, Z, \tau)}{\partial r^2} + \frac{1}{r} \frac{\partial f(R, Z, \tau)}{\partial r} + \frac{\partial^2 f(R, Z, \tau)}{\partial \tau^2} \right]
\]

(11)

At the same time, setting partial differentiation of eq 4 with respect to \( t \) gives

\[
\frac{\partial \tau}{\partial t} = \frac{\partial}{\partial t} \frac{4D}{r_0^2} = \frac{4D}{r_0^2}
\]

(12)

Combination of eqs 11 and 12 gives

\[
\frac{4D \frac{\partial f(R, Z, \tau)}{\partial \tau}}{r_0^2} = D \left[ \frac{\partial^2 f(R, Z, \tau)}{\partial r^2} + \frac{1}{r} \frac{\partial f(R, Z, \tau)}{\partial r} + \frac{\partial^2 f(R, Z, \tau)}{\partial \tau^2} \right]
\]

(13)

Then, \( r \) is replaced with \( R \) in eq 13, which can be expressed as

\[
\frac{4D \frac{\partial f(R, Z, \tau)}{\partial \tau}}{r_0^2} = D \left[ \frac{\partial}{\partial R} \frac{\partial f(R, Z, \tau)}{\partial R} + \frac{1}{r_0} \frac{\partial f(R, Z, \tau)}{\partial R} + \frac{\partial^2 f(R, Z, \tau)}{\partial \tau^2} \right]
\]

(14)

Setting partial differentiation of eq 5 with respect to \( r \) results in

\[
\frac{\partial R}{\partial r} = \frac{\partial}{\partial r} \frac{r}{r_0} = \frac{1}{r_0}
\]

(15)

Combination of eqs 14 and 15 gives

\[
\frac{4D \frac{\partial f(R, Z, \tau)}{\partial \tau}}{r_0^2} = D \left[ \frac{1}{r_0} \frac{\partial f(R, Z, \tau)}{\partial R} + \frac{1}{r_0} \frac{\partial f(R, Z, \tau)}{\partial R} + \frac{\partial^2 f(R, Z, \tau)}{\partial \tau^2} \right]
\]

(16)

which is equivalent to
\[
\frac{4D}{r_0^2} \frac{\partial f}{\partial \tau} = D \left[ \frac{1}{r_0^2} \frac{\partial^2 f}{\partial R^2} + \frac{1}{r_0^2 R} \frac{\partial f}{\partial R} + \frac{\partial^2 f}{\partial z^2} \right]
\]  

(17)

Again, combination of eqs 15 and 17 simplifies eq 17 to

\[
\frac{4D}{r_0^2} \frac{\partial f}{\partial \tau} = D \left[ \frac{1}{r_0^2} \frac{\partial^2 f}{\partial R^2} + \frac{1}{r_0^2 R} \frac{\partial f}{\partial R} + \frac{\partial^2 f}{\partial z^2} \right]
\]  

(18)

Finally, \( z \) is replaced with \( Z \). Eq 18 is equivalent to

\[
\frac{4D}{r_0^2} \frac{\partial f}{\partial \tau} = D \left[ \frac{1}{r_0^2} \frac{\partial f}{\partial R} + \frac{1}{r_0^2 R} \frac{\partial f}{\partial R} + \frac{\partial}{\partial z} \frac{\partial f}{\partial z} \right]
\]  

(19)

Setting partial differentiation of eq 6 with respect to \( z \) results in

\[
\frac{\partial Z}{\partial z} = \frac{\partial}{\partial z} \frac{r}{r_0} = \frac{1}{r_0}
\]  

(20)

Combination of eqs 19 and 20 gives

\[
\frac{4D}{r_0^2} \frac{\partial f}{\partial \tau} = D \left[ \frac{1}{r_0^2} \frac{\partial f}{\partial R} + \frac{1}{r_0^2 R} \frac{\partial f}{\partial R} + \frac{\partial}{\partial z} \frac{1}{r_0} \frac{\partial f}{\partial Z} \right]
\]  

(21)

which is equivalent to

\[
\frac{4D}{r_0^2} \frac{\partial f}{\partial \tau} = D \left[ \frac{1}{r_0^2} \frac{\partial f}{\partial R} + \frac{1}{r_0^2 R} \frac{\partial f}{\partial R} + \frac{1}{r_0} \frac{\partial Z}{\partial z} \frac{\partial^2 f}{\partial Z^2} \right]
\]  

(22)

Again, combination of eqs 20 and 22 gives

\[
\frac{4D}{r_0^2} \frac{\partial f}{\partial \tau} = D \left[ \frac{1}{r_0^2} \frac{\partial f}{\partial R} + \frac{1}{r_0^2 R} \frac{\partial f}{\partial R} + \frac{1}{r_0} \frac{\partial f}{\partial Z} \right]
\]  

(23)

Rearrangement of eq 23 results in

\[
\frac{\partial f}{\partial \tau} = 0.25 \left[ \frac{\partial f}{\partial R} + \frac{1}{R} \frac{\partial f}{\partial R} + \frac{\partial f}{\partial Z} \right]
\]  

(24)

Since \( D_1 = 0.25 \), eq 24 is equivalent to eq 2.

5.2 Dimensionless Current

Since the diffusion equation was defined with respect to dimensionless parameters, it is convenient to convert the current into a dimensionless form (eq 3). As shown in 3.2.1, the flux at the electrode surface depends on \( R \). The current, therefore, is defined as

\[
i(t) = nF \int_0^b -2\pi rJ_r(r,0,t)dr = 2\pi nF \int_0^b rD \left[ \frac{\partial C(r,z,t)}{\partial z} \right]_z = 0 dr
\]  

(25)

Combination of eqs 7 and 25 results in
\[ i(\tau) = 2\pi nFD \int_0^r \left[ \frac{\partial C^* f(R, Z, \tau)}{\partial z} \right] dr = 2\pi nFD C^* \int_0^r \left[ \frac{\partial f(R, Z, \tau)}{\partial z} \right] dr \] (26)

Now \( r \) is replaced with \( R \) in eq 26 so that
\[ i(\tau) = 2\pi nFDC^* \int_0^r R \left[ \frac{\partial f(R, Z, \tau)}{\partial z} \right] dr \] (27)

, which is equivalent to
\[ i(\tau) = 2\pi nFDC^* r_0 \int_0^1 R \left[ \frac{\partial f(R, Z, \tau)}{\partial z} \right] dr \] (28)

Combination of eqs 15 and 28, and rearrangement of the resulting equation gives
\[ i(\tau) = 2\pi nFDC^* r_0 \int_0^1 R \left[ \frac{\partial f(R, Z, \tau)}{\partial z} \right] dR \] (29)

Finally, \( z \) is replace with \( Z \) in eq 29, which is equivalent to
\[ i(\tau) = 2\pi nFDC^* r_0 \int_0^1 R \left[ \frac{\partial Z \partial f(R, Z, \tau)}{\partial z} \right] dR \] (30)

Combination of eqs 20 and 30, and rearrangement of the resulting equation gives
\[ i(\tau) = 2\pi nFDC^* r_0 \int_0^1 R \left[ \frac{\partial f(R, Z, \tau)}{\partial Z} \right] dR \] (31)

At the same time, the diffusion-limited steady-state current is given as
\[ i_{SS} = 4nFDC^* r_0 \] (32)

The dimensionless current \( Z(\tau) \) is defined as
\[ Z(\tau) = \frac{i(\tau)}{i_{SS}} = \int_0^1 \frac{2\pi}{4} R \left[ \frac{\partial f(R, Z, \tau)}{\partial Z} \right] dR \] (33)

Since \( D_i = 0.25 \), eq 33 is equivalent to eq 3. Indeed, FEMLAB gives the right-hand side of eq 3 as an output (see eq 8). It is convenient to define \( Z(\tau) \) in the form of eq 3.