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5 MORE ON THE USE OF THE SPREADSHEET 
Making changes to existing spreadsheets 

 

LEARNING OUTCOMES 
In Lesson 4 you created a grade sheet for a class of 4th graders based on a template you had put 
together at the beginning of the same lesson. You learned that you can easily adapt a template for 
use with other classes that you might teach. You learned about the organization of spreadsheets. 
You learned about rows and columns, and the cells at the intersection of those rows and 
columns. You learned how to select cells and how to address cells using row and column 
coordinates. You learned how to enter formulas into certain cells in order to have Excel do 
calculations for you--totals and percentages in particular.  

You filled the rows and columns with labels and grades. You had a first introduction to the 
idea that a spreadsheet can be a powerful tool for handling numeric data that requires 
mathematical or statistical processing. 

In this tutorial you will have the opportunity to reinforce what you learned in Lesson 4. At 
the same time you will learn how to maintain a spreadsheet. This you will do by making 
enhancements to the spreadsheet you created in Lesson 4. 

You will also learn about some of the logical processing capabilities of spreadsheets, 
capabilities which enable you to give an "intelligent" flavor to the applications that you build. In 
particular, you will learn about the following features of the Excel spreadsheet. 

 Recapitulation and Reinforcement 
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 Updating an existing spreadsheet 
 More changes to the look of the spreadsheet 
 Using the LOOKUP function 
 Creating charts based on spreadsheet data 
 Printing the updated spreadsheet 
 Making a backup copy of your documents 

 
A caveat before you begin: You'll find it easiest to use the tutorial if you follow the directions 
carefully. On computers there are always other ways of doing things, but if you wander off on 
your own be sure you know your way back! 

 

5.1 GETTING STARTED 
Showing the Full menus and organizing the Toolbars 
Recall from Lessons 1 and 2 that, when using any of the Office programs, it is best to be able to 
see the full menus at all times. Unless you set the Customize options to show the full menus, you 
will only see a few of the items in each menu at the top of the Word window. So let's start out by 
setting the Option in Excel to “Always show full menus.” 

Open Microsoft Excel if you have not already done so (on your computer it's 
probably in the Start menu > All Programs > Spreadsheets) 
In the Tools menu, select Customize…, then in the dialog box that pops up, 
select the Options tab (Fig. 5.1) 

  
Fig. 5.1 The Customize dialog box 
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Make sure there is a check mark next to the item to Always show full menus 

While you're at it, check the box next to Show Standard and Formatting toolbars 
on two rows, List font names in their font, and Show ScreenTips on toolbars 

Click the Close button when you're done 

On with the tutorial… 
You're going to work with a Gradebook very similar to the one you created in Lesson 4. But for 
the sake of uniformity, and to avoid confusion, you're going to use documents specially prepared 
for use with this lesson. 

As an exercise at the end of the tutorial you will have the opportunity to incorporate these 
changes into your own gradebook documents (Grade4 2002 and Grades Template) which you 
created when you completed Lesson 4. 

You are going to make some improvements to the layout of the Gradebook, after which you 
will learn about the LOOKUP function as an introduction to the logic capability of Excel. At the 
end of the lesson you will learn how to create and modify charts of various kinds. 

Open Microsoft Excel then put your Work Files for Office 2003 Tutorials 
disk in the disk drive 

You are going to update two documents: 

• a gradebook template (called Grades Template, and stored in the Templates folder inside 
the Work Files folder on your Work Files for Office 2003 Tutorials disk); 

• and an actual gradebook filled with data (this document has the name Gradebook and is 
stored in the Other folder also inside the Work Files folder on your Work Files for Office 
2003 Tutorials disk). 

You will work on the Gradebook document first. 

By now you should know the steps to open a document, so go ahead and 
Open the document Gradebook from the Other folder inside the Work Files 
folder on your Work Files for Office 2003 Tutorials disk 

 

5.2 RECAPITULATION AND REINFORCEMENT 
Lesson 4 has Tables of the most useful Excel spreadsheet commands. You might like to put a 
marker at the relevant pages (pp. 93 and 94) for easy reference while you follow along in this 
tutorial. Alternatively, you can use the chart that is included at the end of this text (inside back 
cover). 

The following sections give you an opportunity to refresh your memory of the basic 
spreadsheet skills you learned in Lesson 4. 

Moving from cell to cell in the spreadsheet 
In Excel spreadsheet terminology the cell that is selected (surrounded by a heavier border) is 
called the current (or active) cell. 

Take a moment now to reacquaint yourself with the methods for changing the position of the 
currently active cell. 
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The arrow keys move the current cell to the adjacent cell left, right, above, or 
below the current cell—press all four of the arrow keys a few times, and watch how 
the current cell moves around 

The TAB key (forward) and the Shift-TAB command (back) also move the 
cursor to the adjacent cell, but only in a horizontal (right or left) direction—try 
these two commands now. 

The RETURN key (forward) and the Shift-RETURN command (back) also move 
the cursor to the adjacent cell, but only in a vertical (up or down) direction—try 
these two commands now 

Use the scroll bars when you want to move around the spreadsheet without 
changing the location of the current cell—try this, too 

More cell selection commands 
Selecting sets of cells in the spreadsheet 
You often may want to highlight all the cells in the spreadsheet --in order to change a font, or 
copy the data to another document, for example. Here's how you do this. 

Click in the empty box above the Row headers and to the left of the Column 
headers (Fig. 5.2) 

 
Fig. 5.2 Selecting an entire spreadsheet 

The entire spreadsheet is now highlighted. However, perhaps you want to select only the cells 
that you're working in.  There are a couple of ways to do this. 

Click anywhere to de-select the selected cells 

For example, use the mouse to drag diagonally down from cell A1 to cell N23 

That's one way. 

Click anywhere to de-select the selected cells 

Now, click in cell A1, hold down the Shift key, and click in cell N23 

The same set of cells is selected.  The Shift key is very useful for selecting a range of cells in 
Excel, or a range of text in Word, or even a range of slides in PowerPoint, which you'll learn 
about soon enough. 

Going to a specific cell anywhere in your spreadsheet 
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If you are working in a large spreadsheet (consisting of thousands of cells) and you know the 
approximate coordinates of a cell you want to find, it is sometimes quicker to let Excel find the 
cell for you. The following steps will make the current cell the one that intersects Column AJ 
and Row 423, a location deep inside the spreadsheet and a long way from the first cell, cell A1. 

From the Edit menu select Go To..., or press ctrl-g 

Type AJ423 (you can use upper case (AJ) or lower case (aj) for the column 
coordinate)--and click on OK, then check that cell AJ423 has been selected 

Check now to see that cell AJ423 is highlighted. Remember that the first (alphabetic) coordinate 
(AJ) is always the column; the second (numerical) coordinate is always the Row. 

Press ctrl-g again, type A1, and click on OK 

You are now back at the first cell. 
You could use the various movement options you read about at the beginning of this 

Reinforcement section. Some would be considerably slower than others, which is why you 
should take the time to familiarize yourself with all the different methods for moving around the 
spreadsheet, especially if you become a regular user of the spreadsheet. 

 

5.3 UPDATING AN EXISTING SPREADSHEET 
The Gradebook document would benefit from some cosmetic changes, such as the following. 

1. There should be double lines to set off different parts of the spreadsheet. It is often useful to 
include double lines between headers and the data, and before summary totals. 

2. It would be useful to include more formulas to increase the information content of the 
spreadsheet. For example, an average for each of the sets of grades so that you and your 
students can see where they stand in relation to the rest of the class on any particular 
assignment or test. A highest score and lowest score for each set of grades would also be 
useful. 

3. It would be a good idea to lock cells containing data that you consider especially important 
to prevent you or someone else accidentally destroying the cell contents. It takes time to put 
together spreadsheet templates and other documents. Some cells will contain functions that 
were tricky to figure out. Locking them will make it difficult to lose your work. 

4. Finally, Excel can do some of the thinking for you if you include a LOOKUP Table to figure 
out the grades for your students based on their percentage score at the end of a reporting 
period. 

Let's deal with these problems one at a time. 
In this section you'll learn how to handle the first three improvements. Using the LOOKUP 

function will be dealt with later in this lesson. 

Dividing up the spreadsheet to make it easier to read 
After you have fixed change #1, the Gradebook document will look similar to Fig. 5.3. 
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Fig. 5.3 Gradebook after update #1 

Breaks between sections of a spreadsheet help the eye locate important data when scanning the 
page, whether on screen or on paper. In Excel, the easiest way to do this is to insert an extra row 
or column at the point where you want to create a division between different parts of the 
spreadsheet, and reduce the width of the row or column so it appears as a double line. Follow 
these steps to update the spreadsheet along the lines of Fig. 5.3. 

On the left edge of the screen, click on Row 13 to select the entire empty row 
Now you want to reduce the row height so it looks like a double line dividing Rows 12 and 14. 

From the Format menu select Row/Height..., then in the Row/Height dialog 
box type the number 4.5 to replace the default height, and click OK 

You need to create a similar dividing line after Row 23, which holds the data for the last student 
in the roster. This is because you are shortly going to include new formulas in Rows 25 thru 27. 

Reduce the height of Row 24 in the same way as you did Row 13, then Save 
the changes you have made 

There are a couple of other ways to change the height of a row or the width of a column. 
One way is to position the mouse on the line between the row or column headers at the point 

where you want to change the height or width. The mouse changes to a cross hair with arrows. 
Then hold down the mouse button and drag to change the height or width of a row or column 
respectively.  A small box appears when you do this (try it for yourself) which tells you the 
height you are selecting.  You already learned in Lesson 4 how to do this for column width. 
Another way is to right click in a cell in the row or column whose height or width you want to 
change.  In the pop up menu you would select to adjust row height or column width, and proceed 
from there.  Very simple. 
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Adding formulas to the spreadsheet 
Excel comes with many built-in functions for the spreadsheet. There are ten categories of 
functions, including Math & Trig functions, Statistical functions, Logical functions, and 
Financial functions, among others. These functions allow the spreadsheet to be tailored to meet 
the needs of myriad numerical data applications from Accounting to Zoological research. 

From the Insert menu select Function... or click on the Insert Function (fx) 
icon in the data entry bar (Fig. 5.4) to take a look at the functions you can 
use 

 
Fig. 5.4 Insert Function (fx) icon in the data entry bar 

Excel displays a dialog box showing a listing of these functions (Fig. 5.5). 

 
Fig. 5.5 The Insert Function dialog box 
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Click to pull down the menu of categories, then select the All option in the 
menu (Fig. 5.5 again) 
Scan through the list of over 200 built-in functions in the Select a Function 
scroll box 

Depending on your math, computing, statistics, or accounting background, you might recognize 
many of them. 

Click on the Cancel button to close the Insert Function dialog box 
Experience is the best way to learn how they work. In Lesson 4 you already learned to use the 
Sum function, and also you created your own formula to calculate the Percentage for each 
student.  
Calculating an average for each of the grade columns  
Next, you are going to add three new functions to the Gradebook: the Average, the Max, and the 
Min functions. You want the value representing the average of the scores in a column to appear 
in a cell in Row 25 at the bottom of each of the columns where you want to calculate an average 
(Fig. 5.6). 

 
Fig. 5.6 Average scores for each column 

Notice in Fig. 5.6 that the last cell in the column of first names has the row label Average. You 
need to do the same in your Gradebook. 

Select cell B25, type the label Average, and press Tab twice to move to cell 
D25 

A word about automatic calculation 
When Automatic Calculation is switched on, Excel immediately carries out any calculations that 
are necessary when you make any changes to the data in the spreadsheet. So you don't have to 
remember to do this yourself. Whenever your spreadsheet is small (like the Gradebook 
document) you will hardly be aware that Excel is working for you like this. If your spreadsheet 
were large, however, you might want to wait till you tell Excel to recalculate all the formulas, 
because of the time it can take to carry out this task. 
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From the Tools menu select Options... then, in the Options dialog box, click 
on the Calculation tab (Fig. 5.7) 

  
Fig. 5.7 Automatic Calculation 

Check to see that the radio button next to Automatic is selected (indicating 
that Automatic Calculation is already selected) 
If not, click on the radio button next to Automatic and click OK 

Back to the task at hand 
The average is computed by adding (SUMming) the set of scores for an assignment or test, and 
then dividing by the number of scores in the set. You could put together this function yourself, of 
course. If you know what it would be for the first column of scores, write it in the box below. 

 

................................................................................................................................................................................ 

It would look something like this: =SUM(D14:D23)/10. But since Excel has a built in Average 
function, you may as well use it. Here is the complete set of steps to include the Average 
function in your spreadsheet. 

Make sure cell D25 is still selected (the cell under the first column of scores), 
then from the Insert menu select Function... 

Select the Statistical category, then select the AVERAGE function from the 
list of Statistical functions and click OK 
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Excel pastes the function into the data entry bar towards the top of the spreadsheet window and 
then selects the cells in the column above the cell in which you want to put the average function. 
It also presents a new dialog box (Fig. 5.8). 

 

Fig. 5.8 The function is first pasted into the Entry bar 

This Function Arguments dialog box selects the set of cells above the cell containing the new 
formula. It also explains what the Average function does, and asks you to confirm the formula by 
clicking OK.  At this stage, you can change any of the cell addresses in the data entry box. 

Notice that Excel has included cell D24 (an empty cell) as part of the set of cells to be 
averaged. This will not affect the result because Excel assumes that an empty cell is not to be 
included in the calculation of the function’s result. 

The formula in the Data Entry bar towards the top of the spreadsheet window should read 
=AVERAGE(D14:D24). Is this the exact wording of the formula on your screen? 

If it is, click OK; if it is not, correct it, then click on OK 
Now look at cell D25. It should contain the average for the scores in Column D. There are 
three problems that can occur: 

1. If you see a series of pound signs (#######...) this indicates that you need to widen the 
column a little so there is enough space for the average score. Either use the Format 
Column/Width... option, or drag with the mouse to make the column wider. If you don't see 
the pound signs (#######...), all well and good.  

2. If a Bad Formula prompt pops up on the screen, check the formula in the entry bar again, 
compare it to the Average formula above, and make any corrections. 

3. If the values being averaged have no decimal places, then the default number of decimal 
places will be zero (0). But it would be useful to show at least one decimal place. Here are 
the steps to change the precision of a decimal number. 

From the Format menu select Cells..., then in the Format Cells dialog 
box (Fig. 5.9 on the next page) select the Number category, and set the 
number of Decimal places (also called precision) to 1 and click on OK 

 142



Lesson 5: More on the Use of the Spreadsheet 

 
Fig. 5.9 Changing the precision of a decimal in the Format cells dialog box 

Assuming all is well, your next task will be to copy this formula into the adjacent cells to the 
right under the other columns of scores (cells E25 through H25). 

Cell D25 should still be selected 

Use the mouse to point at cell D25, then hold down the mouse button and 
drag across to Column H (so cells D25, E25, F25, G25, and H25 will all be 
selected) then from the Edit menu select Fill/Right... 

That's all there is to it. Adjust the column widths if you see pound signs (#) instead of averages. 
It's all good practice. 

Time to save all that hard work (ctrl-s) 

Displaying the Highest and Lowest scores for each column of scores 
Now that you know how to use the Function... option from the Insert menu, and in particular 
since you just used it to put the Average function in your spreadsheet, you can complete the 
exercise that follows. 

You might find it best to read over the directions before carrying them out, since they're a bit 
tricky at first. 

Put a heading in cell B26 (Max score) and in cell B27 (Min score) 

Put the Max function in cell D26 (listed as Max( ) in the Statistical category 
in the Insert Function dialog box)—this function is used to find the highest 
score for each set of scores 
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Drag down with the mouse to select cells D14 through D23, the cells you 
want included as arguments in the Max function (D14:D23), and click OK 

In cell D27 put the Min function (listed as Min( ) in the Statistical category in 
the Insert Function dialog box) and drag with the mouse to select cells D14 
thru D23 once again, then click OK 

Just as you did when you worked on the Average function, copy the new Max 
and Min functions across to the corresponding cells under columns E thru H 
using the Fill/Right... option in the Edit menu 

When you're done, your spreadsheet should resemble that illustrated in Fig. 5.10. 

 

Fig. 5.10 The Gradebook document after adding the functions (your data may be different) 

Locking (protecting) important cells 
Excel allows you to protect the contents of a cell or cells by locking or protecting them. This 
means that neither you nor anyone else will be able to change the contents unless you remove the 
protection. This feature is useful to prevent accidental loss of data, and will also help prevent 
others from interfering with the data you have collected. 

Since all the data in a Gradebook are important, it would be a good idea to protect 
everything. The process to do this is the same as if you were protecting a single cell, or a few 
cells, except that you select every cell. 

Press ctrl-a to Select All the cells in the spreadsheet 
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From the Tools menu select Protection > Protect sheet..., to bring up the 
Protect Sheet dialog box (Fig. 5.11 

Take a look at this dialog box. Notice that you have the option to include a password to remove 
protection (unlock the locked cells).  This is a necessary feature if you want to lock the cells in 
your spreadsheet to prevent students, for example, from changing grades. You would choose a 
password that would be difficult to guess, of course, but also one that you would be sure to 
remember!  You don’t need a password in this exercise, however. 

Click on OK in the Protect Sheet dialog box 

Now all the cells in the Gradebook are unable to be changed unless you select Unlock Cells from 
the Option menu. If you wanted to lock just certain cells you would first select the cell or cells 
and turn on the Protection tool for just that cell or those cells. 

If you try to change a locked cell, you will get a warning dialog box (Fig. 5.12) telling you 
that you can’t change anything unless you first remove the protection. 

 

Fig. 5.12 Protection warning dialog box 

For this reason, later in this tutorial, when you get this warning message, you will need to 
remove the protection on cells in order to make updates. 

Time to save the changes you have made to the Gradebook (ctrl-s). This should be becoming 
instinctive for you by now. 

Dividing the spreadsheet into panes 
Often a spreadsheet, or any type of Excel document for that matter, will be too long or too wide 
to view all at once on the screen. Excel has a useful feature called panes. 

You can split any window horizontally or vertically into sections. This will allow you, while 
working or scrolling in one section, to keep the other section(s) fixed in place. 

To see how this works, from the Window menu select Split... 

Excel immediately divides up the worksheet into four sections, using a vertical and a horizontal 
split bar (Fig. 5.13 on the next page). 

You can change the position of the split bars by positioning the mouse arrow on a split bar 
and drag across or down the screen. 

Try this for practice— position the mouse arrow on either the vertical or 
horizontal split bar (you'll get a cross-hair cursor) and hold down the button 
while you drag across or down the screen 

Notice how easy it is to compare different parts of a spreadsheet in this way. The pane or 
splitting screen feature is available in all Excel applications, but you probably will find that you 
use it most frequently while working with spreadsheets, especially large ones. 
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Fig. 5.13 Excel’s vertical and horizontal split bars 
Removing panes 
This is easy enough to do. 

From the Window menu select Remove Split 
Your spreadsheet should be restored to its original format. 
 

5.4 MAKING MORE CHANGES TO THE LOOK OF THE SPREADSHEET 
In Lesson 4 you learned how to change the size of columns and rows. Now you are going to 
remove the grid lines, and put borders around some cells. 
Putting a border around a cell or set of cells 
You may want to put a box around the Class info in cells A4 through B6. This will make the 
information stand out in a report. Try this now. 

Drag across cells A4 through B6 to select the set of Class info 
The cells of the spreadsheet are still protected, and you’ll have to unprotect them before you can 
make any changes to the cells. 

From the Tools menu, select Protection > Unprotect sheet…, then from the 
Format menu select Cells... to bring up the Format Cells dialog box 
Click on the Border tab in the dialog box (Fig. 5.14) 
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Fig. 5.14 Excel’s Outline feature for cell borders 

As you can see, the Border dialog box gives you various options. 

Click on the Outline preset icon and click on OK, then from the Tools menu 
select Protection > Protect Sheet... and click OK to restore protection to the 
sheet’s cells 

As you can see, the Class Info now has a border around it, setting it off nicely from the rest of 
the data in the gradebook (Fig. 5.15). 

 
Fig. 5.15 Spreadsheet with added features 
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Removing grid lines and column and row headers 
Grid lines and column and row headers are essential when developing a spreadsheet or when one 
is updating the data. But for reporting purposes it may look better, perhaps even easier to read, if 
they are removed. You may recall doing this in Lesson 4. Try this again now for reinforcement. 

From the Tools menu select Options... to bring up the Options dialog box 
(Fig. 5.16) and click on the View tab to select View > Window options 

 
Fig. 5.16 The Options dialog box 

In the Window options section of the dialog box, remove the check mark in 
the boxes next to Gridlines, and Row & column headers, then click on OK 

The spreadsheet now looks quite different, as you can see. 
Practice makes perfect 

On the Work Files for Office 2003 Tutorials disk, open the Work Files 
folder, then open the Templates folder and open the Grades Template 
document 

Now you're going to make the same changes to the Grades template that you just made to 
the Gradebook document. 

Go ahead and update the Grades Template, except DON'T transfer any of 
the actual data from the Gradebook document to the Grades Template 
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spreadsheet—just update the functions and other formatting features you 
added to the Gradebook document (Fig. 5.17 illustrates what you need to do) 

 
Fig. 5.17 Tiling the spreadsheet windows to make changes to the Template 

What you’re doing is making sure that the Grades Template spreadsheet has the same format and 
functions as the Gradebook document so that you can use it with other classes you may have in 
the future. 

The following directions will help you in this reinforcement task. Hint: Use Copy and Paste 
to complete many of the tasks. 

1. As illustrated in Fig. 5.17 above, tile the two spreadsheets so you can see them side by side 
on the screen. Here’s how to do this. 

From the Window menu select Arrange... 
The Tiled option is selected by default, so click on OK 

2. It will be easier to complete these tasks if you bring back the gridlines and the column and 
row headers in the Gradebook document. 

Click anywhere on the Gradebook window to make sure the Gradebook is 
the active window 
From the Tools menu select Options..., then in the Options dialog box 
click on the View tab 
In the Window options section put the check mark back in the boxes next 
to Gridlines and Row & column headers, then click on OK 
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3. If necessary, step again through the section you have just completed (5.4 MORE 

CHANGES TO THE LOOK OF THE SPREADSHEET) completing the same tasks in 
the Grades Template document that you just completed for the Gradebook document. 

Be sure to save the Grades Template when you have finished making the changes. 

When you have finished updating the Grades Template, from the index in 
the Window menu select the document Gradebook so as to make this once 
again the current document on the Desktop 

It might be a good idea to take a break at this point in the tutorial. If you are unable to finish 
everything in one sitting, you should save the Gradebook and the Grades Template documents 
on your Data disk and your Data Backup disk before shutting down the computer. You should 
know how to do this by now, but if you need help with this task, the directions are at the end of 
the lesson. 
 
 

TIME FOR A BREAK? 

FEEL FREE TO TAKE ONE… 

THIS MIGHT BE ENOUGH FOR ONE DAY! 
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5.5 USING THE LOOKUP FUNCTION 
The concept of the LOOKUP function 
The spreadsheet LOOKUP function is a little tricky to understand, so stand up, step back from 
the keyboard for a while and stretch some of those muscles that are stiff from sitting through the 
first part of this tutorial. When you are ready, read quietly through this section to understand how 
the LOOKUP function works. 

The LOOKUP function is a simple logic tool that you can use to automatically assign grades 
to your students based on the numbers in the Percentage column of your spreadsheet (column L). 

You are probably aware by now that if you have the automatic calculation option selected, 
Excel carries out function-based calculations as you make changes in a spreadsheet. Thus, once 
you have programmed Excel to LOOKUP the grades, the system will automatically update each 
student's Letter Grade, along with Totals and Percentages, even as you enter new scores for 
assignments, homework, tests, and so forth. 

Thus, with no effort on your part, you will be able to keep students informed at any time 
during the semester as to exactly what grade they currently carry for the class. 

Such information is invaluable. Knowledge is power. When a student is aware of an 
inadequate grade early on, extra effort can be applied to improve the situation before it is too 
late. It is surprising how often students are unaware of how they stand with regard to their 
progress through a course. The teacher who fails to provide adequate feedback when directing 
students in their pursuit of academic objectives deserves at least some of the blame if students do 
not progress as well as they should. When students are kept apprised at all times of where they 
stand they tend to take more responsibility for the outcomes of their efforts--or lack of them. 

Fig. 5.18 illustrates the LOOKUP Table that will be the outcome of this exercise. 

 

Row headers 

Fig. 5.18 LOOKUP table 
You are going to tell Excel to compare a student's percentage with the range of values in the first 
column of the table. These are control percentages. Excel will search through this first column, 
looking for the highest value (percentage) that is less than or equal to the student's percentage. 
Once that value is located in the first column, the function will assign the student the letter grade 
that is adjacent to it in the second column. 
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Does that make sense? An example will help. Suppose the student's percentage is 87%. Well, in 
the table above the highest value in the first column that is still less than or equal to 87% is 80%, 
is it not? 70%, 60%, and 0% are less than or equal to 87%, but they are not the highest value that 
is less than or equal to 87%. So 80% is the value that Excel will select from the Range column in 
its LOOKUP of the table. The letter grade from the corresponding cell in the second column--in 
this case a "B"--will then be posted to the GRADE column of the gradebook proper. 

Once you understand the concept of "the highest value less than or equal to another number", 
the rest is easy. Here are a few student percentages to try for yourself. Complete the exercise that 
follows. 

From Fig. 5.18, column 1, 

what is the highest value less than or equal to 45%? _____________ 

what is the highest value less than or equal to 67%? _____________ 

what is the highest value less than or equal to 59%? _____________ 

what is the highest value less than or equal to 100%? _____________ 
The answers are in the footnote at the bottom of the page.1 

There are two parts to incorporating the Excel LOOKUP function into your Gradebook. First 
you must build the LOOKUP Table into the spreadsheet. Second you must enter into the 
appropriate cells the LOOKUP function that will instruct Excel to carry out the LOOKUP 
operation. 
Building the LOOKUP Table 

You’ll need both the Gradebook (which you saved in the Other folder in the 
Work Files folder) and the Grades Template (which you saved in the 
Tamplates folder in your Work Files folder) to complete the remainder of this 
tutorial, so if these documents are not already open, open them both from 
your Work Files for Office 2003 Tutorials disk before proceeding 
Next, from the Window menu select the Gradebook document if it is not 
already the active window on the screen 

Since all the cells are protected in the Gradebook document, you’ll need to unlock them first in 
order to make changes. 

From the Tools menu select Protection/Unprotect sheet... 
Now, let’s build the Lookup table that’s illustrated in Fig. 5.18 on the previous page. The first 
column of the LOOKUP Table (the lookup vector) has a set of numbers which Excel calls the 
lookup_vector. 

A vector is just another name for a single column of numbers. This is the set of values 
against which Excel compares the data from a selected cell in the Gradebook. 

Let’s create this column (vector) of the LOOKUP table first. 

Select cell O1 and type the column header Range (%) then press Enter to 
move down to cell O2 

                                                 
1 0%, 60%, 0%, 100% 
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Type 0 (the number zero (0) that is) in cell O2 and press Enter to move down 
to cell O3 

Type 0.6 (this is equivalent to 60% in mathematical terms) and press Enter 
again to select cell O4 

Type 0.7 and press Enter to make O5 the current cell, then type 0.8 and 
press Enter once more 

Type 0.9 in cell O6 and press Enter to make O7 the current cell, then type 1 
(this is equivalent to 100% in mathematical terms) and click on the Accept 
( ) button 

Now you must change the cell attributes of this first column of the table so as to display the 
numbers in percent form (with the percent (%) symbol). You did this before in Lesson 4, so the 
following is just a reminder of how to do this. 

Drag down to highlight all 6 of the scale values from cell O2 to cell O7 

In the Format tool bar click on the % (Percent) symbol to change the format 
of the decimal numbers to percentages 

That completes the first column of the table. Now for the second column with the letter grades--
what Excel calls the result vector. These are the values which Excel returns to the gradebook cell 
in which is the formula which calls the LOOKUP function. 

Select cell P1 and type the header Grade (A-E), then press Enter to move 
down to cell P2 

Type the letter E (or whatever you would use for a failing grade) and press 
Enter to go to cell P3 

Type a D and move down to cell P4, then type a C and move down to cell P5 

Type a B and move on down to cell P6, then type an A and move down to cell 
P7 

Finally type an A again in cell P7 and click on the Accept ( ) button 

The table is now almost ready for use. A couple of cosmetic adjustments will improve its 
appearance. 

Select columns O and P by dragging across the letters O and P at the top of 
the columns 

In the Format toolbar select Center alignment, then in the Format menu 
select Column/Width and make the width 10 

Your LOOKUP Table should now look like Fig. 5.18 above. When you are done, don't forget to 
save all your hard work before proceeding with the tutorial. 
Using the clipboard to copy cells from one document to another 
Now that you have completed the task of building the LOOKUP Table in the Gradebook 
document you should update the template document Grades Template along the same lines. The 
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easiest way to do this is to copy the relevant cells from the Gradebook document into the Grades 
Template document using Copy and Paste. 

First you must copy the relevant cells (those used for the LOOKUP Table) from the 
Gradebook document to the clipboard. Here are the steps. 

Select cell O1 and drag down diagonally across the LOOKUP Table to cell 
P7 

Press ctrl-c to copy the LOOKUP Table to the clipboard 

Now you must switch to the Grades Template document.  

Select Grades Template from the list in the Window menu to make it the 
active document on the Desktop (or click on the Grades Template window 
on your screen) 

Click on cell O1 to make it the current cell 

Press ctrl-v to paste the LOOKUP Table from the clipboard to the Grades 
Template 

Notice that the width of columns O and P in the Grades Template is the default width of 13, 
which is wider than you need for the table. 

In the Grades Template window, change the width of columns O and P to 9, 
then save your work (ctrl-s) once more 

Entering the LOOKUP function into the spreadsheet 
Recall that the LOOKUP function instructs Excel to look up a table that you have built and come 
back with a corresponding result to store in the spreadsheet proper. Still confused? Maybe the 
following will help you figure it out. 

The LOOKUP function has the following parts to it: 

=LOOKUP(lookup _value,lookup_vector,result_vector) 
Let us examine each part of this function in order to understand how it works. 

 As you know, the "=" symbol at the start of the function simply tells Excel that a 
function is in the cell, as opposed to regular data such as numbers or labels. 

 The word LOOKUP tells Excel the task it has to carry out (look something up in a 
list). 

 lookup_value, lookup_vector, and result_vector are variables (control values) that 
Excel uses when it is looking up the table: 

 the lookup_value is either a number or text (such as a person's name); this value 
will be the "key" that Excel will use as it searches through the cells in the 
lookup_vector or column; 

 the lookup_vector is the column of cells that Excel has to check in its lookup of 
the table (column O in Fig. 5.18); 

 the result_vector is the column of cells in which Excel will find the result of the 
LOOKUP operation. 
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Still confused? Maybe an example will help you understand how the Lookup function works. It 
will be easiest for you to follow the next exercise if you have an actual gradebook to work with. 

Begin by switching back to the Gradebook document on the Desktop (use 
the Window menu for this or click on the Gradebook document on your 
screen) 

As you follow along, make sure you have the LOOKUP Table (columns O and P) showing on 
the screen, as well as the last two columns of the gradebook document (columns L and N) 
containing the PCNT and GRADE data. 

Scroll over as far as necessary until you have columns L through P showing 
on the screen with the top of the LOOKUP Table (Row 1) at the top of the 
screen 

Select cell N14 

This is the first cell in the GRADE column. You want Excel to use the LOOKUP function to 
figure out the letter grades for each student and display it in this column (Column N). So this is 
where the LOOKUP function must go. 

From the Insert menu select Function... or click on the Insert Function icon 
(fx) in the data entry bar towards the top of the spreadsheet window 

In the Insert Function dialog box select the category Lookup & Reference, 
then scroll down and in the Select a Function: scroll box click on LOOKUP, 
then click on OK 

This brings up the Select Arguments dialog box (Fig. 5.19). 

 
Fig. 5.19 The Select Arguments dialog box 

The first set of arguments (lookup_value, lookup_vector, result_vector) 
are what we want, and they are already selected by default, so click on OK 

The entry bar at the top of the spreadsheet now contains the basic LOOKUP function, ready for 
you to add the three (3) arguments for the LOOKUP function—the lookup_value, the 
lookup_vector, and the result_vector. 
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Excel also presents a dialog box for you to enter these arguments (Fig. 5.20). 

 
Fig. 5.20 The Function Arguments dialog box for the LOOKUP function 

Entering the lookup_value in the dialog box 
Notice that the cursor is positioned for you to enter the first parameter of the LOOKUP function 
(the lookup_value). You must select the cell which contains this lookup_value. Cell L14 
contains the Percentage for the first student. Well, each student's Percentage will determine the 
grade, so the percentage is what we want Excel to use to find the letter grade from the Lookup 
Table. 

Click on cell L14 
Excel enters this cell's coordinates as the first of the LOOKUP parameters, the lookup_value. 
You are telling Excel that it must use this first student's percentage as the value to check against 
the first column of the LOOKUP Table (O2 through O7). 
Entering in the lookup_vector 
Cells O2 through O7 are the lookup_vector for the LOOKUP Table. 

Click in the second data entry box in the LOOKUP dialog box, the 
lookup_vector entry area, so you can enter the cells which contain the 
lookup_vector 

Use the mouse to drag down from cell O2 to cell O7 in the spreadsheet 

Notice that in the data entry bar Excel fills in the second of the LOOKUP parameters for the 
LOOKUP function, namely the lookup_vector. Check this in the Data entry bar, too. 

Entering the result_vector 
Cells P2 through P7 are the result_vector for the LOOKUP Table. 

Click in the third box in the LOOKUP dialog box so you can specify the cells 
that contain the result_vector 
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Now drag down from cell P2 to cell P7 in the spreadsheet 

Notice, once again, that Excel fills in the third of the LOOKUP parameters, the result_vector. 

Check the data entry bar to see that the LOOKUP function is now complete 

Finally, click on OK 

Applying the function 
Excel will look for "the highest value in cells O2 through O7 that is less than or equal to the 
student's percentage". 

Take a look at cell N14 now and see if it contains the correct grade according 
to the value in cell L14 (the percentage for this first student) 

So, once the LOOKUP function has located the correct cell in column 1 of the Lookup Table 
(the Range column), all that remains is for Excel to make a note of the letter grade that is in the 
corresponding cell in column 2 of the table (the Grade column), and copy of that grade into cell 
N14. 

Copying the LOOKUP function into the rest of the GRADE column 
The first student's grade is taken care of. Now you must copy this function from cell N14 down 
to the other cells in the GRADE column (column N), which need to contain the letter grade for 
the other students in the class. 

If you want to try and do this on your own (you will need to understand the concept of 
Absolute and Relative references!), go ahead. If you are successful you can skip the rest of this 
sub-section and go to the Practice makes perfect section on the next page. 

If you need help completing the LOOKUP function, read on to follow the steps to Fill down 
the LOOKUP function to the remaining cells in column N. 

First you must make a small change to the function itself. You also need to put your thinking 
cap on, because if this is the first time you've used a LOOKUP function, it can get mighty 
confusing. 

You may recall learning about Relative and Absolute cell references in Lesson 4. The 
function =LOOKUP(L14,O2:O7,P2:P7) will work fine for the first student, but if you copy it to 
the other cells as is, Excel will assume that all the cell references in the function are relative to 
the cell into which they are being copied, and will adjust them accordingly, resulting in the 
wrong letter grades. 

But the references to the LOOKUP Table (O2:O7 and P2:P7) are absolute references--they 
must not change--because the required data for the LOOKUP Table will always be found in 
these specific cells. 

So you must tell Excel to leave these LOOKUP Table references unchanged when copying 
the LOOKUP function into the other cells in column N. The reference to the lookup_value (cell 
L14 for the first student), is relative, and should change for each student.  So the reference for 
the second student will be L15, and so on. 

Here is a reminder of the steps to tell Excel to treat certain cell references as Absolute 
References. 

Click on cell N14 
The LOOKUP function is spelled out in full in the Data Entry bar at the top of the screen. 
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Click immediately before the reference to cell O2 in the function in the Data 
entry bar at the top of the spreadsheet 
Now put a dollar ($) sign in front of every reference (rows and columns) to the 
LOOKUP Table (8 $ signs in all) as illustrated in Fig. 5.21 

 
Fig. 5.21 Absolute references are preceded by dollar ($) signs 

This will ensure that this part of the function will remain unchanged ("absolute") when you copy 
it shortly into the other cells in column N. 

Click the Accept button ( ) to accept the LOOKUP function into cell N14 
Here now are the steps to copy the function from cell N14 by Filling Down into the remaining 
cells of the GRADE column (Column N). 

Make sure the current cell is still cell N14 
Drag down column N from cell N14 to the last cell in the column that 
contains a percentage (cell N23) 
From the Edit menu select Fill/Down... 

Excel now takes a moment to complete the copy operation, which includes figuring out the grade 
for each student based on the function that is now embedded in each cell of the GRADE column. 
And you should see the correct letter grade for each student in column N. 

While you have the cells in column N highlighted, center the grades in the 
column 
Protect all the cells in your spreadsheet (Tools menu) since you don't want 
to lose all your hard work 
Save the Gradebook document once again (ctrl-s) 

If you need to think about this a little more, go carefully back over what you have just done. 
Once you have a clear idea of how the LOOKUP function works, you and your students will be 
able to apply it in myriad situations when you build spreadsheets of your own. 
Practice makes perfect 
Your task now is to switch to the Grades Template document again, and add the LOOKUP 
function there, too. Since you do not have any data in the template (or at least you shouldn’t 
have!), your LOOKUP function will produce a column of meaningless grades (all E’s!) in the 
GRADE column, just as was the case when you built a function into the PCNT column of the 
template document when you were working on Lesson 4. This is no problem, because the data 
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will be relevant when you use the spreadsheet with an actual class and enter meaningful sets of 
scores. 

You either can add the functions to the Grades Template document the long way, by 
repeating all the steps you just carried out for the Gradebook document, or you can use the Copy 
(ctrl-c) function as you did a short while ago to copy the LOOKUP Table from the one document 
to the other. 

Don't forget, when you’re done, to save the changes you have made to the 
Grades Template spreadsheet 

 

5.6 CREATING CHARTS BASED ON THE SPREADSHEET DATA 
The concept of using charts 
A spreadsheet user can benefit from charts based on the numbers stored in its rows and columns 
of cells. Charts enable the user to visualize the data. "A picture," as you know, "is worth a 
thousand words." By the same token, a well-designed chart can help you make sense of a 
thousand numbers. Charts are also useful to increase the impact of any oral or written 
presentation. 

For this exercise you’ll open a new spreadsheet document so you can practice creating 
charts. 

On your Work Files for Office 2003 Tutorials disk, in the Work Files folder 
open the Other folder and then open the Charts document 

Your spreadsheet should look like Fig. 5.22. 

 

Fig. 5.22 Data for Charts document 

The Excel charting capability 
Charts are easy to create using the Excel spreadsheet. You may create a chart from information 
gathered from most any spreadsheet. There are dozens of different types of charts that you can 
create. 
Creating a bar chart 
The values represented in a chart are called a data series. In the chart you are about to create, the 
number of students in the various grade ranges will be represented by bars. The chart may have a 
title and a legend which has the names related to the data series. 

Most charts, except pie charts, have axes which are the perpendicular lines along which the 
data is plotted or displayed. The Y axis is the vertical axis, which shows the number of students 
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in each grade range. The X axis is the horizontal axis, which shows the grade range. First you 
have to designate the part of the spreadsheet that you want included in the chart. This is called 
the chart range. 

Select by dragging and highlighting from cell A1 through F2, then click in the 
Standard tool bar on the Chart Wizard tool (Fig. 5.22 above) 

The Chart Wizard dialog box is displayed (Fig. 5.23). 

 
Fig. 5.23 The Chart Wizard dialog box 

Take a few moments to look over the variety of charts and options that Excel offers. 
Click on several of the chart types (Bar, Line, Pie, etc.) 
To see how a chart will eventually look, click on the button that tells you to 
"Press and hold to view sample" 
When you have checked out several of the chart types, select the first Chart 
type: called a Column chart 
In the Chart sub-type section of the dialog box, click on the fourth of the 
seven samples (the clustered column with a 3-D visual effect—see Fig. 
5.23 above), then click on the Next > button 

Step 2 in the Chart Wizard prompts you for the Data Range (the set of cells that contain the data 
you want to use for the chart). You have already selected the data range by dragging across the 
set of cells containing the data for the chart. 

Click on the Next > button 
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Step 3 allows you to enter a title for the chart, as well as descriptions for each axis of the chart. 
These are your next tasks. 

For the chart title enter:  
In the X axis box enter: Grades 
In the Z axis box (it’s a 3-D chart) enter: Number of Students 
Click on Next > to proceed to Step 4 of the Chart Wizard 
Finally, click on the Finish button to accept the default of saving the chart as 
part of the Charts worksheet 

Immediately Excel creates the chart (Fig. 5.24) and displays it on the screen.  

 
Fig. 5.24 Completed Bar Chart 

You can easily make changes to the chart if you want. Try this now. 
Slide the Chart toolbar off to the side if it’s sitting on top of your chart 
Right click on any piece of the chart (title, any other text, the bars, the chart 
background, the gridlines, the chart area as a whole, the legend, the axis 
numbers or letters) 

Notice the handles that immediately appear around the object you've selected.  Also notice that 
each part of the chart has different options in its pop up menu. 

Select an option from the menu that pops up and interact with the dialog box 
to change fonts, colors and so forth 
Try several variations on the look and feel of the chart—experiment; you can 
always undo anything you don't like 
When you're done practicing, save a copy of the bar chart (use Save As…) 
in the Data Files folder on your Work Files for Office 2003 Tutorials disk 
with the name Bar Chart 

That’s all you want to do with the Bar Chart, so you might as well remove it from the 
spreadsheet window before the next exercise. 

Left click real close to the edge of the Bar chart to select the whole chat and 
not some piece of the chart’s contents 
Then hit the Del(ete) key--or from the Edit menu select Cut (ctrl-x) 
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Creating a pie chart 
Creating a pie chart will be straightforward if you just successfully completed the bar chart. You 
will use the same set of data for the exercise that follows. 

Drag to select cells A1 through F2 
In the Standard tool bar click on the Chart Wizard button again 
Select Pie for the Chart type: in the Chart Wizard dialog box 
Now select the Second of the Pie chart sub-types (Fig. 5.25), and click on 
Next > 

 
Fig. 5.25 Pie Chart sub-types 

You already selected the chart source data so click on Next > again 
Enter the chart title: Class Grades and click on Next > 

There’s nothing to change in Step 4, since you want the chart to be saved with the spreadsheet. 
Click on Finish and click in cell A1 to clean up the screen 

If all went well, your pie chart is completed and should like the one in Fig. 5.26. 
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Fig. 5.26 Completed Pie Chart of grade range 

As before with the bar chart, right click on any part of the chart and try some 
different fonts or colors and so forth. 
When you're done experimenting, save a copy of the pie chart in the Data 
Files folder on your Work Files for Office 2003 Tutorials disk with the name 
Pie Chart, then close the spreadsheet by selecting Close from the File menu 

 
5.7 PRINTING THE UPDATED SPREADSHEET 
Selecting a section of the spreadsheet for printing 
You're going to print out the gradebook twice. When you first print out your Gradebook, you do 
not want the LOOKUP Table to appear on the printed report. You want to print only that block 
of cells that contains the data pertaining to student grades for the semester. This includes 
columns A through N and Rows 1 through 27. 

The steps that follow will show you how to select just this block of cells for printing. 

From the Window menu select the spreadsheet document Gradebook  

Make sure the printer is turned on and the paper set up correctly 

Next you must select (highlight) the range of cells that you want to print. 

Drag down diagonally from cell A1 to cell N27 (this will include the Average, 
Max Score, and Min Score summary lines at the bottom of the Gradebook), 
but not the cells with the LOOKUP table 

From the File menu select Page Setup and make sure you have the option for 
Landscape orientation selected for the spreadsheet and click OK 

From the File menu select Print 

Your spreadsheet has just one page. Here are the steps to print just that section of the spreadsheet 
that you have selected. 

In the Print what section, click on the radio button next to Selection 
If you wanted to check on how many pages there are in a spreadsheet before printing, you would 
select Page View from the Window menu, and zoom out as you did earlier in this tutorial by 
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clicking the zoom tool in the Standard toolbar. This will enable you to figure how many pages 
you need to select in the Print dialog box. 

Notice also that in the Print dialog box you can opt to Preview the worksheet before printing. 
Click on Preview now 

The printed spreadsheet will look better if you remove column and row headers as well as the 
cell gridlines. 

Click on Setup... at the top of the Preview window, then click on the Sheet 
tab 
Click to remove the check mark from the boxes next to Gridlines and Row 
and column headers, then click on OK 

Notice how different the spreadsheet looks without the gridlines. 
Save your gradebook one more time, then click on the Print button at the top 
of the Preview window to print out a hardcopy of your gradebook 
Now print a second copy of the Gradebook document, but this time include 
the Lookup Table, along with the gridlines and row and column headers 
If you are completing the lesson for a class at school, hand in both copies of 
the spreadsheet to your instructor 

   
5.8 MAKING A BACKUP COPY OF YOUR DOCUMENTS 
Your last task before completing this session at the computer is to make a backup of your 
document on the backup disk. The Grade 4 2004 gradebook is still open in Excel. It is also saved 
on your Work Files for Office 2003 Tutorials disk, which is in the disk drive. 

Take out your Work Files for Office 2003 Tutorials disk and in its place 
insert your Backup Work Files for Office 2003 Tutorials disk 
From the File menu select Save As... and in the Save As... dialog box 
select the disk drive that holds your Backup Work Files for Office 2003 
Tutorials disk 
Double click to open the Data Files folder, double click again to open the 
Spreadsheets folder, and click on the Save button 
Wait while the file is being saved, then close Excel 

 

LOOKING BACK 
Most people take advantage of only a fraction of the functionality of computer software. This 
tutorial, and the others that you have worked your way through thus far, have introduced you to a 
wider range of features of Excel than most Excel users are aware of. However, you still cannot 
consider yourself an expert, even though you are becoming a sophisticated user. To become an 
expert you must first of all use the software, taking advantage of the features you have learned so 
that you don't forget them. You also might study the User's Guide that Microsoft provides along 
with the Excel software. 

Expertise is ephemeral. "Use it, or lose it," as they say. 
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LOOKING FORWARD 
An exhortation 
Lessons 7 and 8 will help you learn to use the Access database application. But before learning 
this new Office application, it will be good to return to Microsoft Word in order to learn how to 
use the mail merge feature of the word processor. This will be the subject of Lesson 6. 

If you have completed all the tutorials in this book up to this point, you have spent a 
considerable amount of time at the computer. This is the only way to master the machine. Yet it 
is not enough. You must be prepared to strike out on your own, creating documents using the 
productivity tools you are learning in these tutorials to meet your needs both in and out of the 
classroom. 
Deep, assimilated learning takes place only once you are working independently, because to do 
this you have to show that you have understood everything you have learned. Understanding 
leads to transference and acquisition of skills. Tutorials will open the doors to knowledge, and 
hold your hand while you make those first steps toward the acquisition of specific skills. 

But you must have the desire to let go of the hand that guides you. Without this desire, the 
exercises that you are following will be wasted and yield no fruit. With this desire, you will be 
motivated to understand what you are learning so that you can apply it to new situations in your 
own professional experience. 
 

SKILL CONSOLIDATION 
Complete these exercises to reinforce what you have learned in Lesson 5. 
1. List at least 5 applications, other than those presented in these tutorials, for which you think 

you would use the Excel spreadsheet in a classroom environment. 
2. Either alone, or with a group, develop templates for each of the five spreadsheets identified 

in exercise 1. This could be an excellent class project. Each team would develop a different 
set of templates. Then all groups would present their results for review by everyone else in 
the class, and the complete set of templates could be made available on disk for everyone to 
take away from the course. 

3. Load the Gradebook document to the Desktop. 
• Add the function to calculate the average score for each of the tests, quizzes, 

homeworks, etc. The system will add up all the scores and divide by the number of 
cells that contain scores to arrive at the average. You should use the copy function to 
duplicate the functions across the spreadsheet. 

• Save the updated document 
• Print out only the columns that contain the student names and the final totals and 

percentages (so you will need to temporarily delete the columns in between--don't save 
this document!) 

4. Load the Gradebook document onto the Desktop. 
• Add a new column for another set of scores 
• Add a new row for another student 
• Update the functions where necessary 
• Sort the student records based on the First and Last Name columns 
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• Save the updated document 
5. Create a line chart based on a set of values for populations in several cities in the U.S. 

Generate a Bar chart from the data. Research the populations on the web at 
http://geography.miningco.com/science/geography/msub24.htm 

6. Create a pie chart based on a set of values for the amount of rainfall for each of any ten cities 
world wide. Research the rainfall data at the following web address: 
http://www.worldclimate.com/ 


