
Lesson 4: More on the use of the Spreadsheet 

 

97

 
 
 
 
 
 
 
 
 
 
 
 

MORE ON THE USE OF THE SPREADSHEET 
Making changes to existing spreadsheets 

 

LEARNING OUTCOMES 
In Lesson 4 you created a grade sheet for a class of 4th graders based on a template you 
had put together at the beginning of the same lesson. You learned that you can easily 
adapt a template for use with other classes that you might teach. You learned about the 
organization of Spreadsheets. You learned about rows and columns, and the cells at the 
intersection of those rows and columns. You learned how to select cells and how to 
address cells using row and column coordinates. You learned how to enter formulas 
into certain cells in order to have Excel do calculations for you--totals and percentages in 
particular.  

You filled the rows and columns with labels and grades. You had a first introduction 
to the idea that a Spreadsheet can be a powerful tool for handling numeric data that 
requires mathematical or statistical processing. 

In this tutorial you will have the opportunity to reinforce what you learned in 
Lesson 3. At the same time you will learn how to maintain a Spreadsheet. This you will 
do by making enhancements to the Spreadsheet you created in Lesson 3. 

You will also learn about some of the logical processing capabilities of Spreadsheets, 
capabilities which enable you to give an "intelligent" flavor to the applications that you 
build. In particular, you will learn about the following features of the Excel Spreadsheet. 

• Updating an existing worksheet 
• Using the LOOKUP function 
• Creating charts based on the Spreadsheet data 
• Printing the updated Spreadsheet file 
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• Making backup copies of all your work 

 
 
 A caveat before you begin: You'll find it easiest to use the tutorial if you follow 
 the directions carefully. On computers there are always other ways of doing 
 things, but if you wander off on your own be sure you know your way back! 
 

 

4.1 GETTING STARTED 
Showing the Full menus 
Microsoft Office has a silly habit of showing only a few items in the menus when you 
want to use them. If you want to see the full menus, you have to double click on the 
menu name, or slide down to the arrows at the bottom of the menu, or, worse still, wait 
for the full menu to reveal itself, which it will after a few seconds. But for this tutorial, 
we're going to be using quite a few menu items that do not normally appear when you 
first click to select a menu. So let's set the Option in Word to Show Full Menus all the 
time. 

In the Tools menu, select Customize…, then in the dialog box that pops up, 
select the Options tab 
Remove the check mark next to the item Menus Show Recently Used 
Commands First 

There, now you'll get the full menus all the time. If you find this tip useful, and 
you're working a lab where you can't permanently set defaults like this, remember to 
show full menus when you start work using any of the programs in the Office suite 
(Word, Excel, PowerPoint, Access, and so forth). If you have your own computer at 
home, you might like to permanently set this Show Full menus option. It'll save you no 
end of time and annoyance. 
 
You will be working with a Gradesheet similar to the one you created in Lesson 3. For 
the sake of uniformity, however, and to avoid confusion, you will use files specially 
prepared for use with this lesson. As an exercise at the end of the tutorial you will have 
the opportunity to incorporate these changes into your own gradebook files (Grade4 
2000 and GradeTmp) which you created when you completed Lesson 3. 

You are going to make some improvements to the layout of the Gradesheet, after 
which you will learn about the LOOKUP function as an introduction to the logic 
capability of Excel. At the end of the lesson you will learn how to create and modify 
charts of various kinds. 

Start by opening Microsoft Excel then put your WorkDisk in the disk drive 
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Have your Data and DataBkp disks handy, of course, so that you won't forget to 
make a backup copy of all your work when you are done. 

You are going to update two files: 
• a gradebook template (called GradeTmp, and stored in the Tmplates folder on 

your WorkDisk); 
• and an actual gradesheet filled with data (this file has the name Gradebk and is 

stored in the Other folder also on your WorkDisk). 
You will work on the Gradebk file first. 

By now you should know the steps to open a file, so go ahead and Open the 
file Gradebk spreadsheet from the Other folder on your WorkDisk 

 

4.2 RECAPITULATION AND REINFORCEMENT 
Lesson 3 has Tables of the most useful Excel Spreadsheet commands. You might like to 
put a marker at the relevant pages (pp. 68 and 69) for easy reference while you follow 
along in this tutorial. Alternatively, you can use the chart that is included at the end of 
this text (inside back cover). 

The following sections give you an opportunity to refresh your memory of the basic 
Spreadsheet skills you learned in Lesson 3. 

Moving from cell to cell in the Spreadsheet 
In Excel Spreadsheet terminology the cell that is selected (surrounded by a heavier 
border) is called the current (or active) cell. 

Take a moment now to reacquaint yourself with the methods for changing the 
position of the currently active cell. 

• The arrow keys move the current cell to the adjacent cell left, right, above, or 
below the current cell. Press all four of the arrow keys a few times, and watch how 
the current cell moves around. 

• The TAB key (forward) and the Shift-TAB command (back) also move the current 
cell one cell, but only in a horizontal (right or left) direction. Try these two 
commands now. 

• The RETURN key (forward) and the Shift-RETURN command (back) also move 
the current cell one cell, but only in a vertical (up or down) direction. Try these 
two commands now. 

• Use the scroll bars when you want to move around the Spreadsheet without 
changing the location of the current cell. Try this, too. 

More cell selection commands 
Selecting all the cells used in the Spreadsheet 
You often may want to highlight all the cells in the Spreadsheet --in order to change a 
font, or copy the data to another document, for example. Here's how you do this. 

Click in the empty box above Row 1 and to the left of Column A (Fig. 4.1) 
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Fig. 4.1 Selecting entire Spreadsheet 

The entire Spreadsheet is now highlighted and ready for any changes you need to 
make. However, perhaps you want to select only the cells that make up your 
Gradesheet. 

Use the mouse to drag diagonally down from cell A1 to cell N23 
Going to a specific cell anywhere in your Spreadsheet 
If you are working in a large Spreadsheet (consisting of thousands of cells) and you 
know the approximate coordinates of a cell you want to find, it is sometimes quicker to 
let Excel find the cell for you. The following steps will make the current cell the one that 
intersects Column AJ and Row 423, a location deep inside the Spreadsheet and a long 
way from the first cell, Cell A1. 

Double click on the Edit menu name to see the expanded version of the 
menu, then select Go To..., or press ctrl-G 
Type AJ423 (you can use upper case (AJ) or lower case (aj) for the column 
coordinate)--and click on OK 

Remember that the first coordinate is always the column; the second coordinate is 
always the Row. Look at the screen. If necessary scroll across until you can see for 
yourself that the Cell AJ423 is selected. Getting back to Cell A1 is easy enough. 

Press ctrl-G again, type A1, and click on OK 
You are now back at the first cell. You could use the various movement options you 

read about at the beginning of this Reinforcement section. Some would be considerably 
slower than others, which is why you should take the time to familiarize yourself with 
all the different methods for moving around the Spreadsheet, especially if you become a 
regular user of the Spreadsheet. 
 
4.3 UPDATING AN EXISTING SPREADSHEET 
The Gradebk Spreadsheet would benefit from some cosmetic changes. Here are some of 
the problems that need attention. 

1. There should be double lines to set off different parts of the Spreadsheet. It is 
often useful to include double lines between headers and the data, and before 
summary totals, as is common practice in accounting. 
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2. It would be useful to include a few extra formulas to increase the information 
content of the Spreadsheet. For example, how about an average for each of the 
sets of grades so that you and your students can see where they stand in relation 
to the rest of the class on any particular assignment or test. A highest score and 
lowest score for each set of grades would also be useful. 

3. It would be a good idea to lock cells containing data that you consider especially 
important to prevent you or someone else accidentally destroying the cell 
contents. It takes time to put together Spreadsheet templates and other 
documents. Some cells will contain functions that were tricky to figure out. 
Locking them will make it more difficult to lose the fruits of your labors. 

4. Finally, you can tell Excel to do some of the thinking for you by including a 
LOOKUP Table to figure out the grades for your students based on their 
percentage score at the end of a reporting period. 

Let us deal with these problems one at a time. In this section you will learn how to 
handle the first three improvements. Using the LOOKUP function is more complex and 
will be dealt with later in this lesson. 
Dividing up the Spreadsheet to make it easier to read 
After you have fixed change #1, the gradebk document will look like Fig. 4.2. 

 

Fig. 4.2 Gradesheet after update #1 
Breaks between sections of a Spreadsheet help the eye locate important data when 

scanning the page, whether on screen or on paper. In Excel, the easiest way to do this is 
to insert an extra row or column at the point where you want to create a division 
between different parts of the Spreadsheet, and reduce the width of the row or column 
so it appears as a double line. Follow these steps to update the Spreadsheet along the 
lines of Fig. 4.2. 

Click on the Row Number 13 on the left of the screen to highlight the entire 
empty row 
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Now you want to reduce the row height so it looks like a double line dividing Rows 
12 and 14. 

From the Format menu select Row/Height..., then in the Row/Height dialog 
box type the number 4.5 to replace the default height, and click OK 

You need to create a similar dividing line after Row 23 which holds the data for the 
last student in the roster. This is because you are shortly going to include new formulas 
in Rows 25 through 27. 

Reduce the height of Row 24 in the same way as you did Row 13, then Save 
the changes you have made 

Another way to change the height of a row or the width of a column is to position 
the mouse on the line between the row or column headers at the point where you want 
to change the height or width. The mouse changes to a cross hair with arrows. Then you 
just hold down the mouse button and drag to change the height or width of a row or 
column respectively. 
Adding formulas to the Spreadsheet 
Excel comes with many built-in functions for both the Spreadsheet and the Database. 
There are nine categories of functions, including Math and Trig functions, Statistical 
functions, Logical functions, and Financial functions among others. These functions 
allow the Spreadsheet to be tailored to meet the needs of myriad numerical data 
applications from Accounting to Zoological research. 

From the Insert menu select Function... or click on the Paste Function (fx) 
icon in the Standard tool bar to take a look at the functions you can use 

Excel displays a dialog box showing a listing of these functions (Fig. 4.3). 

 
Fig. 4.3 The Paste Function dialog box 
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Click on All and scan through the list in the Function name: scroll box 

Depending on your math, computing, statistics, or accounting background, you 
might recognize many of them. 

Experience is the best way to learn how they work. In Lesson 3 you already learned 
to use the Sum function, and you also created your own formula to calculate the 
Percentage for each student. You are going to use three new functions right now: the 
Average, the Max, and the Min functions. 

Click on the Cancel button to remove the Paste Function dialog box 

Calculating an average for each of the grade columns 
The value representing the average of the scores in a column will appear in the cell in 
Row 25 at the bottom of the column to which it applies (Fig. 4.4). 

 
Fig. 4.4 Average scores for each column 

Notice in Fig. 4.4 that the last cell in the column of names has the row label Average 
entered in it. Your first task is to do the same in your Gradesheet. 

Select Cell B25, type the label Average, and press Tab twice to move to Cell 
D25 

A word about automatic calculation 
When Automatic Calculation is switched on, Excel immediately carries out any 
calculations that are necessary when you make any changes to the data in the 
spreadsheet. So you don't have to remember to do this yourself. Whenever your 
spreadsheet is small (like the gradebk document) you will hardly be aware that Excel is 
working for you like this. If your spreadsheet were large, however, you might want to 
tell Excel to wait till you tell it to recalculate all the formulas, because of the time it can 
take to carry out this task. 

From the Tools menu select Options... then, in the Options dialog box, click 
on the Calculation tab (Fig. 4.5) 
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Check to see that the radio button next to Automatic is selected (indicating 
that Automatic Calculation is already selected) 
If not, click on the radio button next to Automatic and click OK 

Back to the task at hand 
The average is computed by adding (SUMming) the set of scores for an assignment or 
test, and then dividing by the number of scores in the set. You could put together this 
function yourself, of course. If you know what it would be for the first column of scores, 
write it in the box below. 

 

....................................................................................................................................................................................... 

It would look something like this: =SUM(D14:D23)/10. But since Excel has a built in 
Average function, you may as well use it. Here is the complete set of steps to include 
the Average function in your Spreadsheet. 

Make sure Cell D25 is still selected (the cell under the first column of scores), 
then from the Insert menu select Function... 

 

Fig. 4.5 Automatic Calculation 

Select the Statistical category, then select the AVERAGE function from the 
list of Statistical functions and click OK 
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Excel pastes the function into the Entry bar at the top of the screen and then makes 
its own best guess as to which cells you want averaged and presents a new dialog box 
(Fig. 4.6). 

This dialog box selects a set of cells, explains what the Average function does, and 
asks you to confirm its guess by clicking the OK button, or change any of the cell 
addresses in the data entry box. 

Notice that Excel has included cell D24 (an empty cell) as part of the set of cells to be 
averaged. This will not affect the result because Excel assumes that an empty cell is not 
to be included in the calculation of the function’s result. 

The formula in the Data Entry bar should read =AVERAGE(D14:D24) Is this the 
exact wording of the formula on your screen? 

If it is, click OK; if it is not, correct it, then click on OK 
Now look at Cell D25 yourself. It should contain the average for the scores in 

Column D. 

 
Fig. 4.6 The function is first pasted into the Entry bar 

There are three problems that can occur: 

1. If you see a series of pound signs (###) this indicates that you need to widen the 
column a little so there is enough space for the average score--you should know 
how to do this by now (if you don't see the pound signs (###), all well and good). 
Either use the Format Column/Width... option, or use the mouse to make the 
column wider. 

2. If the set of values being averaged has no decimal places, then the default number 
of decimal places will be zero (0). But it would be useful to show at least one 
decimal place here. Here are the steps to change the precision of a decimal 
number. 
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From the Format menu select Cells..., then in the Format Cells dialog 
box (Fig. 4.7) select the Number category, and set the number of decimal 
places (also called precision) to 1 and click on OK 

3. If a Bad Formula prompt pops up on the screen, check the formula in the entry 
bar again, compare it to the Average formula above, and make any corrections. 

Assuming all is well, your next task will be to copy this formula into the adjacent 
cells to the right under the other columns of scores (cells E25 through H25). 

Cell D25 should still be selected 
Use the mouse to point at Cell D25, then hold down the mouse button and 
drag across to Column H (so Cells D25, E25, F25, G25, and H25 will all be 
selected) then from the Edit menu select Fill/Right... 

That's all there is to it. Adjust the column widths if you see pound signs (#) instead 
of averages. It's all good practice. 

Time to save all that hard work (ctrl-S) 

 

Fig. 4.7 Changing the precision of a decimal in the Format cells dialog box 

Displaying the Highest and Lowest scores for each column of scores 
Now that you know how to use the Function... option from the Insert menu, and in 
particular since you just used it to put the Average function in your spreadsheet, you 
can complete the exercise that follows. You might find it best to read over the directions 
before carrying them out, since they're a bit tricky at first. 
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Put a heading in cell B26 (Max score) and in cell B27 (Min score) 
Put the Max function in cell D26 (listed as Max( ) in the Statistical category 
in the Paste Function dialog box)—this function is used to find the highest 
score for each set of scores 
Drag down with the mouse to select cells D14 through D23, the cells you 
want included as arguments in the Max function (D14:D23), and click OK 
In cell D27 put the Min function (listed as Min( ) in the Statistical category in 
the Paste Function dialog box) and drag with the mouse to select cells D14 
thru D23 once again 
To copy the new Max and Min functions across to the corresponding cells 
under the other columns of scores (E thru H) use the Fill/Right... option in 
the Edit menu, as you did when you worked on the Average function just now 

When you're done, your spreadsheet should resemble that illustrated in Fig. 4.8. 

 
Fig. 4.8 The Gradebk Spreadsheet after adding the functions 
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Locking (protecting) important cells 
Excel allows you to protect the contents of a cell by locking or protecting it. This means 
that neither you nor anyone else will be able to change the contents unless you remove 
the protection. This feature is useful to prevent accidental loss of data, and will also 
help prevent others from interfering with the data you have collected. 

Since all the data in a Gradesheet are important, it would be a good idea to protect 
everything. The process to do this is the same as if you were protecting a single cell, or a 
few cells, except that you select every cell. 

From the Tools menu select Protection/Protect sheet..., then click on OK in 
the dialog box that pops up on the screen 

Now all the cells in the Gradesheet are unable to be changed unless you select 
Unlock Cells from the Option menu. If you wanted to lock just certain cells you would 
first select the cell or cells and turn on the Protection tool for just that cell or those cells. 

If you try to change a locked cell, you will get an warning dialog box (Fig. 4.9) 
telling you that you can’t change anything unless you first remove the protection. 

 
Fig. 4.9 Protection warning dialog box 

For this reason, later in this tutorial, when you get this warning message, you will 
need to remove the protection on cells in order to make updates. 

Time to save the changes you have made to the Gradesheet (ctrl-S). This should be 
becoming instinctive for you by now. 
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Dividing the Spreadsheet into panes 
Often a Spreadsheet, or any type of Excel document for that matter, will be too long or 
too wide to view all at once on the screen. Excel has a useful feature called panes. 

You can split any window horizontally or vertically into sections. This will allow 
you, while working or scrolling in one section, to keep the other section(s) fixed in 
place. 

To see how this works, double click on the Window menu, and select Split... 
Excel immediately divides up the worksheet into four sections, using a vertical and a 

horizontal split bar (Fig. 4.10). You can change the position of the split bars by 
positioning the mouse arrow on a split bar and hold down the button while you drag 
across or down the screen. Try this for practice. 

Notice how easy it is to compare different parts of a spreadsheet in this way. The 
pane or splitting screen feature is available in all Excel applications, but you probably 
will find that you use it most frequently while working with Spreadsheets, especially 
large ones.  

 
Fig. 4.10 Excel’s vertical and horizontal split bars 

Removing panes 
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From the Window menu select Remove Split 
Your Spreadsheet should be restored to its original format. 

Changing the look of the Spreadsheet 
In Lesson 3 you learned how to change the size of columns and rows. Now you are 
going to remove the grid lines, and put borders around some cells. 

Putting a border around a cell or set of cells 
You may want to put a box around the Class info in Cells A4 through B6. This will 
make the information stand out in a report. Try this now. 

 
Fig. 4.11 Excel’s Outline feature for cell borders 

Drag across Cells A4 through B6 to select the set of Class info 
The cells of the spreadsheet are still protected, and you’ll have to unprotect them 

before you can make any changes to the cells. 
From the Tools menu select Protection/Unprotect sheet, then from the 
Format menu select Cells... to bring up the Format Cells dialog box 
Click on the Border tab in the dialog box (Fig. 4.11) 

As you can see, the Border dialog box gives you various options. 
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Click on the Outline preset icon and click on OK, then select 
Protection/Protect Sheet... to restore protection to the sheet’s cells 

The Class Info now has a border around it, setting it off nicely (Fig. 4.12). 

 
Fig. 4.12 Spreadsheet with added features 

Removing grid lines and column and row headers 
Grid lines and column and row headers are essential when developing a spreadsheet or 
when one is updating the data. But for reporting purposes it may look better, perhaps 
even easier to read, if they are removed. Try this for yourself. 

From the Tools menu select Options... to see the Options dialog box (Fig. 
4.13) and click on the View tab to select the View options 

 
Fig. 4.13 The Options dialog box 
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In the Window options section of the dialog box, remove the check mark in 
the boxes next to Gridlines, and Row & column headers, then click on OK 

The Spreadsheet suddenly looks quite different, as you can see. 

Practice makes perfect 

Open the Tmplates folder on your WorkDisk and load the GradeTmp file 
onto the Desktop 
Make the same changes to it that you just made to the Gradebk file, except 
that you won’t transfer any of the actual data from the Gradebk 
spreadsheet to the GradeTmp spreadsheet 

What you’re doing is making sure that the GradeTmp spreadsheet has the same design 
as the Gradebk spreadsheet so that you can use it with other classes in the future. 

The following directions will help you in this reinforcement task. 

 
Fig. 4.13b Tiling the Spreadsheet windows 

1. Tile the two spreadsheets so you can see them side by side on the screen (Fig. 
4.13b above). Here’s how you do this. 

From the Window menu select Arrange... 

Make this template look like 
the actual gradebook 
without the student data--
but keep the functions… 
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The Tiled option is selected by default, so click on OK 
2. It will be easier to complete these tasks if you have the gridlines and the column 

and row headers in the Gradebk spreadsheet. 

Click anywhere on the Gradebk spreadsheet window to make sure the 
Gradebk spreadsheet is the active window 
From the Tools menu select Options... 
In the Options dialog box click on the View tab 
In the Window options section put the check mark back in the boxes next 
to Gridlines and Row & column headers, then click on OK 

3. Use the Copy and Paste commands to complete many of the tasks. 

4. If necessary, step again through the section you have just completed (4.3 
UPDATING AN EXISTING SPREADSHEET) doing the work in the GradeTmp 
file that you just completed for the Gradebk file. 

Be sure to save the GradeTmp when you have finished making the changes. 

When you have finished updating the GradeTmp, select the file Gradebk 
from the index in the Window menu so as to make this once again the 
current file on the Desktop 

It might be a good idea to take a break at this point in the tutorial. If you are unable 
to finish it in one sitting, you should save the Gradebk and the GradeTmp files on your 
Data and DataBkp disks before shutting down the computer. If you need help with this 
task, the directions are at the end of the lesson. 
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TIME FOR A BREAK? 

FEEL FREE TO TAKE ONE. 

THIS MIGHT BE ENOUGH FOR ONE DAY! 
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4.4 USING THE LOOKUP FUNCTION 

The concept of the LOOKUP function 
The Spreadsheet LOOKUP function is a little tricky to understand, so stand up, step 
back from the keyboard for a while and stretch some of those muscles that are stiff from 
sitting through the first part of this tutorial. When you are ready, read quietly through 
this section to understand how the LOOKUP function works. 

The LOOKUP function is a simple logic tool that you can use to automatically assign 
grades to your students based on the numbers in the Percentage column of your 
Spreadsheet (column L). 

You are probably aware by now that if you have the automatic calculation option 
selected, Excel carries out function-based calculations as you make changes in a 
Spreadsheet. Thus, once you have programmed Excel to LOOKUP the grades, the 
system will automatically update each student's Letter Grade, along with Totals and 
Percentages, even as you enter new scores for assignments, homework, tests, and so 
forth. 

Thus, with no effort on your part, you will be able to keep students informed at any 
time during the semester as to exactly what grade they currently carry for the class. 

Such information is invaluable. Knowledge is power. When a student is aware of an 
inadequate grade early on, extra effort can be applied to improve the situation before it 
is too late. It is surprising how often students are unaware of how they stand with 
regard to their progress through a course. The teacher who fails to provide adequate 
feedback when directing students in their pursuit of academic objectives deserves at 
least some of the blame if students do not progress as well as they should. When 
students are kept apprised at all times of where they stand they tend to take more 
responsibility for the outcomes of their efforts--or lack of them. 

Fig. 4.13 illustrates the LOOKUP Table that will be the outcome of this exercise. 

 

Fig. 4.14 LOOKUP table 

You are going to tell Excel to compare a student's percentage with the range of 
values in the first column of the table. These are control percentages. Excel will search 
through this first column, looking for the highest value (percentage) that is less than or 
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equal to the student's percentage. Once that value is located in the first column, the 
function will assign the student the letter grade that is adjacent to it in the second 
column. 

Does that make sense? An example will help. Suppose the student's percentage is 
87%. Well, in the table above the highest value in the first column that is still less than or 
equal to 87% is 80%, is it not? 70%, 60%, and 0% are less than or equal to 87%, but they 
are not the highest value that is less than or equal to 87%. So 80% is the value that Excel 
will select from the Range column in its LOOKUP of the table. The letter grade from the 
corresponding cell in the second column--in this case a "B"--will then be posted to the 
GRADE column of the gradesheet proper. 

Once you understand the concept of "the highest value less than or equal to another 
number", the rest is easy. Here are a few student percentages to try for yourself. 
Complete the exercise that follows. 

From Fig. 4.13, column 1, 
what is the highest value less than or equal to 45? _____________ 
what is the highest value less than or equal to 67? _____________ 
what is the highest value less than or equal to 59? _____________ 
what is the highest value less than or equal to 100? _____________ 

The answers are in the footnote at the bottom of the page.1 
There are two parts to incorporating the Excel LOOKUP function into your 

Gradesheet. First you must build the LOOKUP Table into the Spreadsheet. Second you 
must enter into the appropriate cells the LOOKUP function that will instruct Excel to 
carry out the LOOKUP operation. 

Building the LOOKUP Table 
You’ll need both the Gradebk and the GradeTmp spreadsheets open to 
complete the remainder of this tutorial, so if these documents are not on the 
desktop, open them from the WorkDisk before proceeding 
Next, from the Window menu select the Gradebk document if it is not 
already the active window on the screen 

Since all the cells are protected in the Gradebk spreadsheet you’ll need to unlock 
them first in order to make changes. 

From the Tools menu select Protection/Unprotect sheet... 
It will also be a good idea to put back the gridlines and row and column headers for 

the next exercise. 

If necessary, from the Tools menu select Options..., then in the Options 
dialog box click on the Views tab and click to put a check mark in the boxes 
next to Gridlines and Row & column headers 

                                                 
1 0%, 60%, 0%, 100% 
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Now, let’s build the Lookup table that’s illustrated in Fig. 4.14. The first column of 
the LOOKUP Table has the values for what Excel calls the lookup_vector. This is the 
scale of values against which Excel compares the data from a cell in the Gradesheet. 
Let’s create this column of the LOOKUP table first. 

Select cell O1 and type the column header Range (%) then press Enter to 
move down to cell O2 

Type 0 (the number zero (0) that is) in cell O2 and press Enter to move down 
to cell O3 

Type 0.6 (this is equivalent to 60% in mathematical terms) and press Enter 
again to select Cell O4 

Type 0.7 and press Enter to make O5 the current cell, then type 0.8 and 
press Enter once more 

Type 0.9 in Cell O6 and press Enter to make O7 the current cell, then type 1 
(this is equivalent to 100% in mathematical terms) and click on the Accept 
( ) button 

Now you must change the cell attributes of this first column of the table so as to 
display the numbers in percent form (with the percent (%) symbol). You did this before 
in Lesson 3, so the following is just a reminder of how to do this. 

Drag down to highlight all 6 of the scale values from Cell O2 to Cell O7 

In the Format tool bar click on the % (Percent) symbol to change the format 
of the decimals to recognizable percentages 

That completes the first column of the table. Now for the second column with the 
letter grades--what Excel calls the result_vector. These are the values which Excel 
returns to the gradesheet cell in which is the formula which calls the LOOKUP function. 

Select cell P1 and type the header Grade (A-E), then press Enter to move 
down to cell P2 

Type the letter E (or whatever you would use for a failing grade) and press 
Enter to go to Cell P3 

Type a D and move down to Cell P4, then type a C and move down to Cell 
P5 

Type a B and move on down to Cell P6, then type an A and move down to 
cell P7 

Finally type an A again in cell P7 and click on the Accept ( ) button 

The table is now almost ready for use. A couple of cosmetic adjustments will 
improve its appearance. 
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Select columns O and P by dragging across the letters O and P at the top of 
the columns 

In the Format toolbar select Center alignment, then in the Format menu 
select Column/Width and make the width 9 

Your LOOKUP Table should now look like Fig. 4.14 above. When you are done, 
don't forget to save all your hard work before proceeding with the tutorial. 

Using the clipboard to copy cells from one document to another 
Now that you have completed the task of building the LOOKUP Table in the Gradebk 
file you should update the template file GradeTmp along the same lines. The easiest 
way to do this is to copy the relevant cells from the Gradebk file into the GradeTmp file 
using the Excel Copy function and the clipboard. 

First you must copy the relevant cells (those used for the LOOKUP Table) from the 
Gradebk file to the clipboard. Here are the steps. 

Select Cell O1 at the top left corner of the table and drag down diagonally 
across the LOOKUP Table to Cell P7 

Press ctrl-C to copy the LOOKUP Table to the clipboard 

Now you must switch to the GradeTmp file.  

Select GradeTmp from the index in the Window menu to make it the active 
file on the Desktop 

Click on Cell O1 to make it the current cell 

Press ctrl-V to paste the LOOKUP Table from the clipboard to the file 
GradeTmp 

Notice that the width of columns O and P in the GradeTmp is the default width of 
13, which is wider than you need for the table. 

Change the width of columns O and P to 9, then save your work (ctrl-S) once 
more 

Entering the LOOKUP function into the Spreadsheet 
Recall that the LOOKUP function instructs Excel to go look up the table you have built 
and return with a result to store in the Spreadsheet proper. The LOOKUP function has 
the following parts to it: 

=LOOKUP(lookup _value,lookup_vector,result_vector) 

Let us examine each part of this function in order to understand how it works. 
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• As you know, the "=" symbol simply tells Excel that a function is in the 
 cell, as opposed to regular data such as numbers or labels. 
• The word LOOKUP tells Excel the task it has to perform. 
• lookup_value, lookup_vector, and result_vector are variables (control 
 values) that guide Excel when it is looking up the table: 
 • lookup_value is either a number or text (such as a name); this value  
 will be the "key" that Excel will use to guide it as it searches through  
 the range of cells specified in the lookup_vector variable; 
 • lookup_vector specifies the series of cells that Excel has to search in its  
 lookup of the table; 
 • result_vector specifies the series of cells the same number of cells as in  
 the lookup_vector) from which Excel will get the result of the   
 LOOKUP operation; 

An example is the best way to understand what is involved. 
It will be easiest for you to follow the next exercise if you have an actual gradesheet 

to work with. So begin by switching back to the Gradebk Spreadsheet on the Desktop 
(use the Window menu for this). As you follow along, make sure you have the 
LOOKUP Table showing on the screen, as well as the last two columns of the 
gradesheet (columns L and N) containing the PCNT and GRADE data. 

Scroll over as far as necessary until you have columns L through P showing 
on the screen with the top of the LOOKUP Table (Row 1) at the top of the 
screen 

Select Cell N14 

This is the first cell in the GRADE column. You want Excel to figure out the letter 
grades for this column (Column N), so this is where the LOOKUP function must go. 

From the Insert menu select Function... or click on the Paste Function icon 
(fx) in the Standard tool bar at the top of the screen 

In the Paste Function dialog box select the Function category titled 
Lookup & Reference, then click on LOOKUP in the Function name: scroll 
box, and click on OK 

This brings up the Select Arguments dialog box. 

The first set of arguments is what we want, and it’s already selected by 
default, so click on OK 

The entry bar now contains the basic LOOKUP function, ready for you to add the 
lookup_value and ranges.  Excel also presents a dialog box for you to enter the three (3) 
arguments for the LOOKUP function—the lookup_value, the lookup_vector, and the 
result_vector. 
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Entering in the lookup_value 
Notice that the cursor is positioned for you to enter the first parameter of the LOOKUP 
function (the lookup_value). You must select the cell which contains this lookup_value. 
Cell L14 contains the Percentage for the first student, which is the "lookup_value" 
required as the first variable in the LOOKUP function. 

Click on Cell L14 

Excel fills in the first of the LOOKUP parameters, the lookup_value. You are telling 
Excel that it must use this first student's percentage as the value to check against the first 
column of the LOOKUP Table (O2 through O7). 

Entering in the lookup_vector 
Cells O2 through O7 are the lookup_vector for the LOOKUP Table. 

Click in the second data entry box in the LOOKUP dialog box so you can 
enter the cells which contain the lookup_vector 

Use the mouse to drag down from Cell O2 to Cell O7 in the Spreadsheet 

Excel fills in the second of the LOOKUP parameters, the lookup_vector. Check this 
in the Data entry bar. 

Entering the result_vector 
Cells P2 through P7 are the result_vector for the LOOKUP Table. 

Click in the third box in the LOOKUP dialog box so you can enter the cells 
that contain the result_vector in the LOOKUP function in the Data entry bar 
at the top of the spreadsheet 

Now drag down from Cell P2 to Cell P7 in the Spreadsheet 

Notice, once again, that Excel fills in the third of the LOOKUP parameters, the 
result_vector. 

Finally, click on OK 

Applying the function 
Excel will look for "the highest value in Cells O2 through O7 that is less than or equal to 
the student's percentage". 

Take a look at Cell N14 now and see if it contains the correct grade according 
to the value in cell L14 (the percentage for this first student) 

Once the LOOKUP function has located the correct cell in column 1 (the Range 
column) of the table, all that remains is for Excel to make a note of the value that is in 
the corresponding cell in column 2 (the Grade column) of the table, and make a copy of 
that grade in cell N14. 
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Copying the LOOKUP function into the rest of the GRADE column 
The first student's grade is taken care of. Now you must copy this function from Cell 
N14 down to all the other cells in the GRADE column (column N). 

If you want to try and do this on your own (you will need to understand the concept 
of Absolute and Relative references!), go ahead. If you are successful you can skip the 
rest of this sub-section. If you need help, read on to follow the steps to Fill down the 
LOOKUP function to the remaining cells in column N. 

First you must make a small change to the function itself. 
You may recall learning about Relative and Absolute cell references in Lesson 3. The 

function =LOOKUP(L14,O2:O7,P2:P7) will work fine for the first student, but if you 
copy it to the other cells as is, Excel will assume that all the cell references in the function 
are relative to the cell into which they are being copied, and will therefore adjust them 
accordingly. 

But the references to the LOOKUP Table (O2:O7 and P2:P7) are absolute references--
they must not change) because the LOOKUP Table will always be found in these 
particular cells. 

So you must tell Excel to leave these LOOKUP Table references unchanged when 
copying the LOOKUP function into the other cells in column N. The reference to the 
lookup_value (Cell L14 for the first student), however, is relative, and should change 
for each student (the reference for the second student will be L15, and so on). 

Here is a reminder of the steps to tell Excel to treat certain cell references as Absolute 
References. 

Click on Cell N14 

The LOOKUP function is spelled out in full in the Data Entry bar at the top of the 
screen. 

Click immediately before the reference to Cell O2 in the function in the Data 
entry bar at the top of the spreadsheet 

Now put a dollar ($) sign in front of every reference (rows and columns) to the 
LOOKUP Table (8 $ signs in all) as illustrated in Fig. 4.15 

 
Fig. 4.15 Absolute references are preceded by dollar ($) signs 

This will ensure that this part of the function will remain unchanged ("absolute") 
when you copy it shortly into the other cells in column N. 

Click the Accept button ( ) to accept the LOOKUP function into Cell N14 

Here now are the steps to copy the function from Cell N14 by Filling Down into the 
remaining cells of the GRADE column (Column N). 

Make sure the current cell is still Cell N14 
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Drag down column N from Cell N14 to the last cell in the column that 
contains a percentage (Cell N23) 

From the Edit menu select Fill/Down... 

Excel now takes a moment to complete the copy operation, which includes figuring 
out the grade for each student based on the function that is now embedded in each cell 
of the GRADE column. And you should see the correct letter grade for each student in 
column N 

While you have the cells in column N highlighted, center the grades in the 
column 

Protect all the cells in your spreadsheet (Tools menu) since you don't want 
to lose all your hard work 

Save the Gradebk file once again (ctrl-S) 

If you need to think about this a little more, go carefully back over what you have 
just done. Once you have a clear idea of how the LOOKUP function works, you and 
your students will be able to apply it in myriad situations when you build Spreadsheets 
of your own. 

Practice makes perfect 
Your task now is to switch to the GradeTmp file again, and add the LOOKUP function 
there, too. Since you do not have any data in the template (or at least you shouldn’t 
have!), your LOOKUP function will produce a column of meaningless grades (all E’s!) 
in the GRADE column, just as was the case when you built a function into the PCNT 
column of the template file when you were working on Lesson 3. This is no problem, 
because the data will be relevant when you use the Spreadsheet with an actual class and 
enter meaningful sets of scores. 

You either can add the functions to the GradeTmp file the long way, by repeating all 
the steps you just carried out for the Gradebk file, or you can use the Copy (ctrl-C) 
function as you did a short while ago to copy the LOOKUP Table from the one 
document to the other. 

Don't forget to save the changes you have made to the GradeTmp 
spreadsheet 

 

4.5 CREATING CHARTS BASED ON THE SPREADSHEET DATA 
The concept of using charts 
A Spreadsheet user can benefit from charts based on the numbers stored in its rows and 
columns of cells. Charts enable the user to visualize the data. "A picture," as you know, 
"is worth a thousand words." By the same token, a well-designed chart can help you 
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make sense of a thousand numbers. Charts are also useful to increase the impact of any 
oral or written presentation. 

For this exercise you’ll open a new Spreadsheet file so you can practice creating 
charts. 

Open the file Charts which is in the Other folder on your WorkDisk 

Your Spreadsheet should look like Fig. 4.16. 

 

Fig. 4.16 Data for Charts file 

The Excel charting capability 
Charts are very easy to create using the Excel Spreadsheet. You may create a chart from 
information gathered from most any Spreadsheet. There are dozens of different types of 
charts that you can create. 

Creating a bar chart 
The values represented in a chart are called a data series. In the chart you are about to 
create, the number of students in the various grade ranges will be represented by bars. 
The chart may have a title and a legend which has the names related to the data series. 

Most charts, except pie charts, have axes which are the perpendicular lines along 
which the data is plotted or displayed. The Y axis is the vertical axis, which shows the 
number of students in each grade range. The X axis is the horizontal axis, which shows 
the grade range. First you have to designate the part of the Spreadsheet that you want 
included in the chart. This is called the chart range. 

Select by dragging and highlighting from Cell A1 through F2, then click in the 
Standard tool bar on the Chart Wizard button (Fig. 4.17) 

 

Fig. 4.17 The Chart Wizard button in the Standard tool bar 

The Chart Wizard dialog box is displayed (Fig. 4.18). 
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Fig. 4.18 The Chart Wizard dialog box 

Take a few moments to look over the variety of charts and options that Excel offers. 
To see how each chart will eventually look, click on the button that tells you to "Press 
and hold to view sample". 

The Chart type: called a Column chart is selected by default. This is what you want. 

For the Chart sub-type click on the fourth of the seven samples (the 
clustered column with a 3-D effect—see Fig. 4.18 above), then click on the 
Next> button 

Step 2 in the Chart Wizard prompts you for the Data Range which you have already 
selected by dragging across the set of cells containing the data you want included in the 
chart. 

Click on the Next> button 

Step 3 allows you to enter a title for the chart, as well as descriptions for each axis of 
the chart. These are your next tasks. 



Lesson 4: More on the use of the Spreadsheet 

 

125

For the chart title enter: Grades for Semester 1, Grade 4 

In the X axis box enter: Grades 

In the Z axis box (it’s a 3D chart) enter: Number of Students 

Click on Next> to proceed to Step 4 of the Chart Wizard 

Finally, click on the Finish button to accept the default of saving the chart as 
part of the Charts worksheet 

Immediately Excel creates the chart (Fig. 4.19) and displays it on the screen. It also 
displays the Chart toolbar so you can easily make changes to the chart if you so wish. 
Try this now. 

 

Fig. 4.19 Completed Bar Chart 

Slide the Chart toolbar out of the way if it’s sitting on top of your chart 

Right click on any piece of the chart (title, any other text, the bars, the chart 
background, the gridlines, the chart area as a whole, the legend, the axis 
numbers or letters), then select an option from the menu that pops up and 
interact with the dialog box to change fonts, colors and so forth 

When you're done having fun, save a copy of the bar chart (use Save As) 
with the name BarChart 

Creating a pie chart 

Click on the Bar chart to select it, then from the Edit menu select Cut (ctrl-
X) 

Creating a pie chart will be straightforward if you just successfully completed the 
bar chart. You will use the same set of data for the next exercise. 
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Drag from Cell A1 through F2 

In the Standard tool bar click on the Chart Wizard button again 

Select Pie for the Chart type: in the Chart Wizard dialog box 

Now select the Second of the Pie chart sub-types (Fig. 4.20), and click on 
Next> 

 

Fig. 4.20 Pie Chart sub-types 

You already selected the chart source data so click on Next> again 

Enter the chart title: Class Grades and click on Next> 

There’s nothing to change in Step 4 since you want the chart to be saved with the 
spreadsheet. 

Click on Finish and click in cell A1 to clean up the screen 
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If all went well, your pie chart is completed and should like the one in Fig. 4.21. 

 
Fig. 4.21 Completed Pie Chart of grade range 

Right click on any part of the chart and try some different fonts or colors and 
so forth. 
When you're ready, save a copy of the pie chart with the name PieChart, 
then close the Spreadsheet by selecting Close from the File menu 

 

4.6 PRINTING THE UPDATED SPREADSHEET 

Selecting a section (block) of the Spreadsheet for printing 
Select the Spreadsheet file Gradebk from the Window menu 

When you print out your Gradesheet, you do not want the LOOKUP Table to 
appear on the printed report. You want to print only that block of cells that contains the 
data pertaining to student grades for the semester. This includes columns A through N 
and Rows 1 through 27. The steps that follow will show you how to select just this block 
of cells for printing. 

Make sure the printer is turned on, and the paper set up correctly 
Next you must select (highlight) the range of cells that you want to print. 

Drag down diagonally from cell A1 to Cell N27 (this will include the Average, 
Max Score, and Min Score summary lines at the bottom of the Gradesheet) 
You already selected Landscape orientation for the spreadsheet, so from the 
File menu select Print 

Your Spreadsheet has just one page. 
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In the Print dialog box, in the Print range section, type 1 in both the From: 
and To: boxes 
In the Print what section, click on the radio button next to Selection 

If you wanted to check on how many pages there are in a Spreadsheet before 
printing, you would select Page View from the Window menu, and zoom out as you 
did earlier in this tutorial by clicking the zoom tool in the Standard toolbar. This will 
enable you to figure how many pages you need to select in the Print dialog box. 

Notice also that in the Print dialog box you can opt to Preview the worksheet before 
printing. 

Click on Preview now 

The printed spreadsheet will look better if you remove column and row headings as 
well as the cell gridlines. 

Click on Setup... at the top of the Preview window, then click on the Sheet 
tab 

Click to remove the check mark from the boxes next to gridlines and Row 
and column headings, then click on OK 

Notice how different the spreadsheet looks without the gridlines. 

Finally, Save your gradebook once more, then click on the Print button at the 
top of the Preview window to print out a hardcopy of your gradebook  

   

4.7 MAKING A BACKUP COPY OF YOUR FILES 
Your last task before completing this session at the computer is to make a backup of 
your files on your WorkDiskBkp disk. The Gradebk and GradeTmp spreadsheet files are 
saved on your WorkDisk disk, which is in the disk drive. 

Close the Excel spreadsheet program 

Close or minimize any other windows that may be open on your desktop to 
make it easier for you to see what you’re doing 

Double click to open the My Computer icon, then double click on 3 1/2 
floppy A: 

Now drag the Other folder from your WorkDisk disk to the Desktop and drop 
it there, then drag the Tmplates folder to the desktop and drop it there 

Watch while Windows makes a copy of your folders on to the desktop, then 
close the Window on your WorkDisk disk 

Remove your WorkDisk disk from the disk drive, replace it with your 
WorkDiskBkp disk and double click on 3 1/2 floppy A: 
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Now drag the Other folder and the Tmplates folder from the desktop to your 
WorkDiskBkp disk 

 

LOOKING BACK 
Most people take advantage of only a fraction of the functionality of computer software. 
This tutorial, and the others that you have worked your way through thus far, have 
introduced you to a wider range of features of Excel than most Excel users are aware of. 
However, you still cannot consider yourself an expert, even though you are becoming a 
sophisticated user. To become an expert you must first of all use the software, taking 
advantage of the features you have learned so that you don't forget them. You also 
might study the User's Guide that Microsoft provides along with the Excel software. 

Expertise is ephemeral. "Use it, or lose it," as they say. 

 

LOOKING FORWARD 
An exhortation 
Lessons 6 and 7 will help you learn to use the Access Database application. If you have 
completed all the tutorials in this book up to this point, you have spent a considerable 
amount of time at the computer. This is the only way to master the machine. Yet it is not 
enough. You must be prepared to strike out on your own, creating documents using the 
productivity tools you are learning in these tutorials to meet your needs both in and out 
of the classroom. 

Deep, assimilated learning only takes place once you are working independently, 
because to do this you have to show that you have understood everything you have 
learned. Understanding leads to transference and acquisition of skills. Tutorials will 
open the doors to knowledge, and hold your hand while you make those first steps 
toward the acquisition of specific skills. But you must have the desire to let go of the 
hand that guides you. Without this desire, the exercises that you are following will be 
wasted and yield no fruit. With this desire, you will be motivated to understand what 
you are learning so that you can apply it to new situations in your own professional 
experience. 

 

SKILL CONSOLIDATION 
Complete these exercises to reinforce what you have learned in Lesson 4. 
1. List at least 5 applications, other than those presented in these tutorials, for which 

you think you would use the Excel Spreadsheet in a classroom environment. 
2. Either alone, or with a group, develop templates for each of the five Spreadsheets 

identified in exercise 1. This could be an excellent class project. Each team would 
develop a different set of templates. Then all groups would present their results for 
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review by everyone else in the class, and the complete set of templates could be 
made available on disk for everyone to take away from the course. 

3. Load the Gradebk file to the Desktop. 
• Add the function to calculate the average score for each of the tests, quizzes, 

homeworks, etc.  
 The system will add up all the scores and divide by the number of cells that 

contain scores to arrive at the average. You should use the copy function to 
duplicate the functions across the Spreadsheet. 

• Save the updated file 
• Print out only the columns that contain the student names and the final totals 

and percentages (so you will need to temporarily delete the columns in 
between--don't save this file!) 

4. Load the Gradebk file onto the Desktop. 
• Add a new column for another set of scores 
• Add a new row for another student 
• Update the functions where necessary 
• Sort the student records based on the First and Last Name columns 
• Save the updated file 

5. Create a line chart based on a set of values for populations in several cities in the 
U.S. Generate a Bar chart from the data. Research the populations on the web at 
http://geography.miningco.com/science/geography/msub24.htm 

6. Create a pie chart based on a set of values for the amount of rainfall for each of any 
ten cities world wide. Research the rainfall data at the following web address: 
http://www.worldclimate.com/ 


